Edgewall Software
Modify

Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#7162 closed defect (duplicate)

Trac default title suffix causes massive Google pollution

Reported by: Sam Hocevar Owned by: Christopher Lenz
Priority: normal Milestone:
Component: admin/console Version: 0.10.4
Severity: major Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

By default Trac appends "- Trac" to each title page (top of header.cs). While this improves Trac's overall visibility, it also causes massive search engine pollution. With a trac, trac here and a trac, trac there, here a trac, there a trac, everywhere a trac, trac.

Looking for proper information about Trac is now impossible. Any request is highly polluted by unrelated Trac installations.

For instance, I was looking for a possible script to paste the Timeline information on an IRC channel. Quite naturally, my first try was "trac IRC bot" on Google. Alas! What I get are hits for Trac installations of the rbot, EnvBot or IRC Bot Workbench projects, which have absolutely nothing to do with Trac.

Another example was just before submitting this bug report. I was wondering whether anyone else was annoyed by the pollution, so quite naturally I looked for "trac page title" on Google to see whether the problem with page titles was mentioned somewhere. And as you can see, there are hundreds of results, none of which have anything to do with Trac.

And yes, I know how to play with inurl:, intitle: and site: keywords when doing Google searches. They just don't work well enough against that kind of search engine pollution.

Attachments (0)

Change History (2)

comment:1 by Emmanuel Blot, 12 years ago

Resolution: duplicate
Status: newclosed

Duplicate of #6628

in reply to:  description comment:2 by Christian Boos, 12 years ago

Replying to Sam Hocevar:

… With a trac, trac here and a trac, trac there, here a trac, there a trac, everywhere a trac, trac.

Yeah, that's the plan :-)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Christopher Lenz.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Christopher Lenz to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.