Edgewall Software
Modify

Opened 14 years ago

Closed 14 years ago

#7140 closed defect (duplicate)

Updating opened report does not work with $USER

Reported by: octavian Owned by: Matthew Good
Priority: normal Milestone:
Component: report system Version: devel
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

When I browse a simple report, I use update button to refresh the results.

But if the report makes use of $USER variable, the update button does not work as expected. Username switches to blank and the result set changes.

I tested this just on non-SQL reports.

Attachments (0)

Change History (2)

comment:1 by Emmanuel Blot, 14 years ago

Milestone: 0.110.11.1
Severity: blockernormal

Please be fair w/ severity and priority settings

comment:2 by osimons, 14 years ago

Milestone: 0.11.3
Priority: highnormal
Resolution: duplicate
Status: newclosed

I presume you mean the Custom Query with the reference to 'update' button and non-sql.

In #1467 this was fixed so that the $USER variable does not get messed up (bug). However, I'm sure the main reason for your problem ('username switches to blank') is that you have restrict_owner to true (owner is a drop-down), in which case it is a duplicate of #7258.

Closing as duplicate, but please reopen if this is not correct.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Matthew Good.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Matthew Good to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.