Edgewall Software
Modify

Opened 11 years ago

Closed 11 years ago

#7096 closed defect (duplicate)

IntegrityError: columns cookie, ipnr, name are not unique

Reported by: Emmanuel Blot Owned by: Jonas Borgström
Priority: low Milestone:
Component: web frontend/tracd Version: devel
Severity: minor Keywords:
Cc: Branch:
Release Notes:
API Changes:

Description

When several browsers are used to access the same tracd instance and the login page (basic HTTP authentication) is requested with the same username, the following error is always thrown to the second (and subsequent) browser instances.

Although this issue does not really occur with a regular use of Trac, it is really painful for Trac and plugin development, while validating rendering with various browsers.

The error magically disappears after a random number of refresh of the login page. It is triggered with virtually every browser.

(no sure about the component, though)

File "trunk/trac/web/main.py", line 417, in _dispatch_request
  dispatcher.dispatch(req)
File "trunk/trac/web/main.py", line 197, in dispatch
  resp = chosen_handler.process_request(req)
File "trunk/trac/web/auth.py", line 101, in process_request
  self._do_login(req)
File "trunk/trac/web/auth.py", line 141, in _do_login
  req.remote_addr, int(time.time())))
File "trunk/trac/db/util.py", line 50, in execute
  return self.cursor.execute(sql_escape_percent(sql), args)
File "trunk/trac/db/sqlite_backend.py", line 58, in execute
  args or [])
File "trunk/trac/db/sqlite_backend.py", line 50, in _rollback_on_error
  return function(self, *args, **kwargs)
Trac: 0.11dev-r6612
Python: 2.5.1 (r251:54863, Jan 17 2008, 19:35:17)
setuptools: 0.6c7
SQLite: 3.4.0
pysqlite:	2.3.5
Genshi: 0.4.4
Pygments: 0.9
Subversion: 1.4.4 (r25188)
jQuery: 1.2.3

Attachments (0)

Change History (2)

comment:1 by Emmanuel Blot, 11 years ago

See also #2570.

comment:2 by Christopher Lenz, 11 years ago

Resolution: duplicate
Status: newclosed

Duplicate of #2570.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted.
to The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.