Edgewall Software
Modify

Opened 11 years ago

Closed 11 years ago

#7066 closed defect (duplicate)

Attachment error

Reported by: lasantha@… Owned by: Christopher Lenz
Priority: normal Milestone:
Component: web frontend/mod_python Version: 0.10
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:

Description

I tried to make an attachment (2kb) and got the following error on error log

[Wed Apr 02 11:28:32 2008] [error] [client 124.43.215.18] PythonHandler trac.web.modpython_frontend: Traceback (most recent call last):, referer: http://220.247.214.140/tracs/Poroject1/attachment/ticket/2?action=new
[Wed Apr 02 11:28:32 2008] [error] [client 124.43.215.18] PythonHandler trac.web.modpython_frontend:   File "C:\\Python24\\Lib\\site-packages\\mod_python\\apache.py", line 299, in HandlerDispatch\n    result = object(req), referer: http://220.247.214.140/tracs/Poroject1/attachment/ticket/2?action=new
[Wed Apr 02 11:28:32 2008] [error] [client 124.43.215.18] PythonHandler trac.web.modpython_frontend:   File "C:\\Python24\\Lib\\site-packages\\trac\\web\\modpython_frontend.py", line 87, in handler\n    gateway.run(dispatch_request), referer: http://220.247.214.140/tracs/Poroject1/attachment/ticket/2?action=new
[Wed Apr 02 11:28:32 2008] [error] [client 124.43.215.18] PythonHandler trac.web.modpython_frontend:   File "C:\\Python24\\Lib\\site-packages\\trac\\web\\wsgi.py", line 87, in run\n    response = application(self.environ, self._start_response), referer: http://220.247.214.140/tracs/Poroject1/attachment/ticket/2?action=new
[Wed Apr 02 11:28:32 2008] [error] [client 124.43.215.18] PythonHandler trac.web.modpython_frontend:   File "C:\\Python24\\Lib\\site-packages\\trac\\web\\main.py", line 351, in dispatch_request\n    req = Request(environ, start_response), referer: http://220.247.214.140/tracs/Poroject1/attachment/ticket/2?action=new
[Wed Apr 02 11:28:32 2008] [error] [client 124.43.215.18] PythonHandler trac.web.modpython_frontend:   File "C:\\Python24\\Lib\\site-packages\\trac\\web\\api.py", line 166, in __init__\n    self.args = self._parse_args(), referer: http://220.247.214.140/tracs/Poroject1/attachment/ticket/2?action=new
[Wed Apr 02 11:28:32 2008] [error] [client 124.43.215.18] PythonHandler trac.web.modpython_frontend:   File "C:\\Python24\\Lib\\site-packages\\trac\\web\\api.py", line 182, in _parse_args\n    fs = cgi.FieldStorage(fp, environ=self.environ, keep_blank_values=True), referer: http://220.247.214.140/tracs/Poroject1/attachment/ticket/2?action=new
[Wed Apr 02 11:28:32 2008] [error] [client 124.43.215.18] PythonHandler trac.web.modpython_frontend:   File "C:\\Python24\\lib\\cgi.py", line 530, in __init__\n    self.read_multi(environ, keep_blank_values, strict_parsing), referer: http://220.247.214.140/tracs/Poroject1/attachment/ticket/2?action=new
[Wed Apr 02 11:28:32 2008] [error] [client 124.43.215.18] PythonHandler trac.web.modpython_frontend:   File "C:\\Python24\\lib\\cgi.py", line 650, in read_multi\n    environ, keep_blank_values, strict_parsing), referer: http://220.247.214.140/tracs/Poroject1/attachment/ticket/2?action=new
[Wed Apr 02 11:28:32 2008] [error] [client 124.43.215.18] PythonHandler trac.web.modpython_frontend:   File "C:\\Python24\\lib\\cgi.py", line 532, in __init__\n    self.read_single(), referer: http://220.247.214.140/tracs/Poroject1/attachment/ticket/2?action=new
[Wed Apr 02 11:28:32 2008] [error] [client 124.43.215.18] PythonHandler trac.web.modpython_frontend:   File "C:\\Python24\\lib\\cgi.py", line 665, in read_single\n    self.read_lines(), referer: http://220.247.214.140/tracs/Poroject1/attachment/ticket/2?action=new
[Wed Apr 02 11:28:32 2008] [error] [client 124.43.215.18] PythonHandler trac.web.modpython_frontend:   File "C:\\Python24\\lib\\cgi.py", line 687, in read_lines\n    self.read_lines_to_outerboundary(), referer: http://220.247.214.140/tracs/Poroject1/attachment/ticket/2?action=new
[Wed Apr 02 11:28:32 2008] [error] [client 124.43.215.18] PythonHandler trac.web.modpython_frontend:   File "C:\\Python24\\lib\\cgi.py", line 715, in read_lines_to_outerboundary\n    line = self.fp.readline(1<<16), referer: http://220.247.214.140/tracs/Poroject1/attachment/ticket/2?action=new
[Wed Apr 02 11:28:32 2008] [error] [client 124.43.215.18] PythonHandler trac.web.modpython_frontend: TypeError: readline() takes exactly 1 argument (2 given), referer: http://220.247.214.140/tracs/Poroject1/attachment/ticket/2?action=new

Attachments (0)

Change History (3)

comment:1 by Emmanuel Blot, 11 years ago

Component: generalweb frontend/mod_python
Owner: changed from Jonas Borgström to Christopher Lenz
Severity: criticalnormal

Not critical as long as the important details are not provided, such as the Trac version number.

comment:2 by anonymous, 11 years ago

Version: 0.10-stable

comment:3 by Christian Boos, 11 years ago

Resolution: duplicate
Status: newclosed
Version: 0.10-stable0.10

Duplicate of #3984, so you must be using 0.10.

Note that you should upgrade to at least 0.10.4 (0.10.5 or 0.11b2 preferred), as earlier 0.10.x versions have too many bugs.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Christopher Lenz.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.