Edgewall Software
Modify

Opened 14 years ago

Closed 14 years ago

Last modified 21 months ago

#7061 closed defect (wontfix)

TypeError: ord() expected a character, but string of length 0 found

Reported by: jdykstra Owned by: Jonas Borgström
Priority: normal Milestone:
Component: general Version: 0.11b2
Severity: normal Keywords: plugin
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

Search for the word "test" Other search words seem to work ok.

How to Reproduce

While doing a GET operation on /search, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'q': u'test'}

User Agent was: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b4) Gecko/2008030714 Firefox/3.0b4

System Information

Trac 0.11b2
Python 2.5.2 (r252:60911, Feb 21 2008, 13:11:45) [MSC v.1310 32 bit (Intel)]
setuptools 0.6c8
SQLite 3.3.4
pysqlite 2.3.2
Genshi 0.4.4
mod_python 3.3.1
Pygments 0.9
Subversion 1.4.6 (r28521)
jQuery: 1.2.3

Python Traceback

Traceback (most recent call last):
  File "c:\python25\lib\site-packages\Trac-0.11b2-py2.5.egg\trac\web\main.py", line 419, in _dispatch_request
    dispatcher.dispatch(req)
  File "c:\python25\lib\site-packages\Trac-0.11b2-py2.5.egg\trac\web\main.py", line 196, in dispatch
    resp = chosen_handler.process_request(req)
  File "c:\python25\lib\site-packages\Trac-0.11b2-py2.5.egg\trac\search\web_ui.py", line 106, in process_request
    results += list(source.get_search_results(req, terms, filters))
  File "build\bdist.win32\egg\doxygentrac\doxygentrac.py", line 208, in get_search_results
    for result in  self._search_in_documentation(doc, keywords):
  File "build\bdist.win32\egg\doxygentrac\doxygentrac.py", line 356, in _search_in_documentation
    results += self._search(fd, keyword)
  File "build\bdist.win32\egg\doxygentrac\doxygentrac.py", line 394, in _search
    idx = self._readInt(fd)
  File "build\bdist.win32\egg\doxygentrac\doxygentrac.py", line 444, in _readInt
    return (ord(b1) << 24) | (ord(b2) << 16) | (ord(b3) << 8) | ord(b4)
TypeError: ord() expected a character, but string of length 0 found

Attachments (0)

Change History (1)

comment:1 by Emmanuel Blot, 14 years ago

Keywords: plugin added
Resolution: wontfix
Status: newclosed

From the trace, it appears the issue is trigger by the Doxygen plugin.

Please report plugin issues to their respective maintainer.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.