Edgewall Software
Modify

Opened 14 years ago

Closed 14 years ago

#6841 closed defect (duplicate)

trac-admin catches exception when permission is added twice

Reported by: nathan.knuth@… Owned by: Christopher Lenz
Priority: normal Milestone:
Component: admin/console Version: 0.11b1
Severity: minor Keywords: trac-admin
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

Trac var/opt/trac/cyboot> Trac var/opt/trac/cyboot> permission add corporate_users TICKET_MODIFY Trac var/opt/trac/cyboot> permission add corporate_users TICKET_MODIFY Traceback (most recent call last):

File "/usr/bin/trac-admin", line 8, in <module>

load_entry_point('Trac==0.11b1', 'console_scripts', 'trac-admin')()

File "/usr/lib/python2.5/site-packages/Trac-0.11b1-py2.5.egg/trac/admin/console.py", line 1198, in run

admin.run()

File "/usr/lib/python2.5/site-packages/Trac-0.11b1-py2.5.egg/trac/admin/console.py", line 119, in run

self.cmdloop()

File "/usr/lib/python2.5/cmd.py", line 142, in cmdloop

stop = self.onecmd(line)

File "/usr/lib/python2.5/site-packages/Trac-0.11b1-py2.5.egg/trac/admin/console.py", line 102, in onecmd

rv = cmd.Cmd.onecmd(self, line) or 0

File "/usr/lib/python2.5/cmd.py", line 219, in onecmd

return func(arg)

File "/usr/lib/python2.5/site-packages/Trac-0.11b1-py2.5.egg/trac/admin/console.py", line 393, in do_permission

self._do_permission_add(user, action)

File "/usr/lib/python2.5/site-packages/Trac-0.11b1-py2.5.egg/trac/admin/console.py", line 429, in _do_permission_add

self._permsys.grant_permission(user, action)

File "/usr/lib/python2.5/site-packages/Trac-0.11b1-py2.5.egg/trac/perm.py", line 320, in grant_permission

self.store.grant_permission(username, action)

File "/usr/lib/python2.5/site-packages/Trac-0.11b1-py2.5.egg/trac/perm.py", line 226, in grant_permission

(username, action))

File "/usr/lib/python2.5/site-packages/Trac-0.11b1-py2.5.egg/trac/db/util.py", line 50, in execute

return self.cursor.execute(sql_escape_percent(sql), args)

File "/usr/lib/python2.5/site-packages/Trac-0.11b1-py2.5.egg/trac/db/sqlite_backend.py", line 58, in execute

args or [])

File "/usr/lib/python2.5/site-packages/Trac-0.11b1-py2.5.egg/trac/db/sqlite_backend.py", line 50, in _rollback_on_error

return function(self, *args, kwargs)

sqlite3.IntegrityError: columns username, action are not unique root@vinson:/var/opt/trac#

Attachments (1)

tracbug.txt (2.0 KB ) - added by nathan.knuth@… 14 years ago.
trac-admin exeception log

Download all attachments as: .zip

Change History (2)

by nathan.knuth@…, 14 years ago

Attachment: tracbug.txt added

trac-admin exeception log

comment:1 by osimons, 14 years ago

Milestone: 0.11.1
Resolution: duplicate
Status: newclosed

Duplicate of #6348.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Christopher Lenz.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Christopher Lenz to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.