Edgewall Software
Modify

Opened 14 years ago

Closed 14 years ago

Last modified 7 years ago

#6772 closed defect (fixed)

PostgreSQL 8.3 upgrade

Reported by: etienne.pub@… Owned by: Christian Boos
Priority: normal Milestone: 0.10.5
Component: version control Version: 0.10.4
Severity: critical Keywords: postgresql, source, browse
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

I'm running Trac 0.10.4 on Apache/Windows with PostgreSQL as a database backend, and SVN as a repository backend. I upgraded PotgreSQL to the new 8.3 release, and when I click on "Browse source" on the interface, I end up with the following error:

Ooops … Trac detected an internal error:

Python Traceback

Traceback (most recent call last):
  File "C:\Python24\Lib\site-packages\trac\web\main.py", line 406, in dispatch_request
    dispatcher.dispatch(req)
  File "C:\Python24\Lib\site-packages\trac\web\main.py", line 237, in dispatch
    resp = chosen_handler.process_request(req)
  File "C:\Python24\Lib\site-packages\trac\versioncontrol\web_ui\browser.py", line 143, in process_request
    self._render_directory(req, repos, node, rev)
  File "C:\Python24\Lib\site-packages\trac\versioncontrol\web_ui\browser.py", line 168, in _render_directory
    changes = get_changes(self.env, repos, [i['rev'] for i in info])
  File "C:\Python24\Lib\site-packages\trac\versioncontrol\web_ui\util.py", line 37, in get_changes
    changeset = repos.get_changeset(rev)
  File "C:\Python24\Lib\site-packages\trac\versioncontrol\cache.py", line 45, in get_changeset
    self.authz)
  File "C:\Python24\Lib\site-packages\trac\versioncontrol\cache.py", line 247, in __init__
    "WHERE rev=%s", (rev,))
  File "C:\Python24\Lib\site-packages\trac\db\util.py", line 50, in execute
    return self.cursor.execute(sql_escape_percent(sql), args)
  File "C:\Python24\Lib\site-packages\trac\db\util.py", line 50, in execute
    return self.cursor.execute(sql_escape_percent(sql), args)
ProgrammingError: operator does not exist: text = integer
LINE 1: SELECT time,author,message FROM revision WHERE rev=1
                                                          ^
HINT:  No operator matches the given name and argument type(s). You might need to add explicit type casts.

I tried to create a fresh environment (new database, new empty repository), and as soon as I populated my repository, I got the same error.

Attachments (0)

Change History (3)

comment:1 by Christian Boos, 14 years ago

Milestone: 0.10.5
Resolution: fixed
Status: newclosed

Duplicate of #6274, also fixed for 0.10.5 (r6416).

I'm closing that as fixed for 0.10.5 instead of duplicate, so that it appears fixed in that milestone as well.

comment:2 by Christian Boos, 14 years ago

Also, please reopen this ticket if you have other issues with PostgreSQL 8.3 when running 0.10.5dev.

comment:3 by Ryan J Ollos, 7 years ago

Keywords: postgresql source browse → postgresql, source, browse

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Christian Boos.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Christian Boos to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.