Edgewall Software
Modify

Opened 12 years ago

Closed 10 years ago

#6661 closed enhancement (duplicate)

ticket view should customize based on ticket type

Reported by: eoin.dunne@… Owned by: Jonas Borgström
Priority: normal Milestone:
Component: ticket system Version:
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:

Description

I swear I entered this ticket before but I just spent 15 minutes searching and found nothing. So sorry if this is a duplicate…

What would be super useful is if the ticket form could change what fields are visible (particularily custom fields), based on the ticket type.

I wrote the TestCaseManagement Plugin on Track hacks. One of the requirements is that the user add a ticket type called testcase, and for reporting purposes they should add a testcase result field.

however, this field (testcase result), doesn't make much sense when submitting a defect.

The extra custom fields clutter up the view.

maybe an extra attribute in the config file under the custom fields like

customFieldName.name.visible = (always or tickettype)

So if the custom field had a visible=always the field would always be visible for all ticket types. If visible=testcase(for example type is testcase) then the field would only be visible for that particular ticket type.

Attachments (0)

Change History (7)

comment:1 by eoin.dunne, 12 years ago

oh I'm guessing this would require javascript to change the ticket form if the ticket type changed (or re-post to the server for an updated view).

comment:2 by Noah Kantrowitz, 12 years ago

Resolution: worksforme
Status: newclosed

This is already implemented in the CondFields plugin.

comment:3 by Christian Boos, 12 years ago

Resolution: worksforme
Status: closedreopened

comment:4 by Christian Boos, 12 years ago

Resolution: duplicate
Status: reopenedclosed

(fixing resolution)

Duplicate of #2464.

comment:5 by anonymous, 12 years ago

Milestone: 0.11.1

comment:6 by anonymous, 10 years ago

Priority: normalhigh
Resolution: duplicate
Severity: normalmajor
Status: closedreopened
Type: enhancementdefect
Version: 0.11-stable

CondFields does not work properly with trac 0.11. The author of the plugin cannot be reached (his email address is from a domain that has expired). Can anyone provide a fix or maintain this plugin?

comment:7 by Remy Blank, 10 years ago

Priority: highnormal
Resolution: duplicate
Severity: majornormal
Status: reopenedclosed
Type: defectenhancement
Version: 0.11-stable

This is still a duplicate of #2464. And please don't mix up the ticket fields. Thanks.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.