Edgewall Software
Modify

Opened 12 years ago

Closed 12 years ago

#6594 closed enhancement (duplicate)

When adding Milestones, they should also, optionally, be added as tickets.

Reported by: anonymous Owned by: Christopher Lenz
Priority: normal Milestone:
Component: roadmap Version:
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:

Description

Sometimes it would be convenient if milestones could have other milestones as dependencies. Ex. Milestone: Release 1.0 Might have Milestones: Add Major Feature X Update Documentation to reflect version changes Beta Test 1.0 Move to New DB in addition to any other Enhancement/Bug tickets

The easiest way I see to implement this is to have milestones be added as tickets, with a severity of "milestone". The ticket can then, optionally, be assigned a milestone.

So in the above example, I would create Milestone "Beta Test 1.0". A new ticket with severity "milestone" would be created. I could then assign the ticket to the "Release 1.0" milestone.

When calculating the progress of a milestone, you would include the progress of any sub-milestones.

When you marked a milestone as complete, the corresponding ticket would be closed; if you closed the ticket, the milestone would be marked as complete.

Attachments (0)

Change History (1)

comment:1 by Emmanuel Blot, 12 years ago

Resolution: duplicate
Status: newclosed

Duplicate of #3003

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Christopher Lenz.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Christopher Lenz to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.