Edgewall Software
Modify

Opened 15 years ago

Closed 12 years ago

#6554 closed defect (worksforme)

trac-admin allows to init environment with mysql errors

Reported by: techtonik@… Owned by: Christopher Lenz
Priority: normal Milestone:
Component: admin/console Version: 0.11b1
Severity: major Keywords: mysql
Cc: Thijs Triemstra Branch:
Release Notes:
API Changes:
Internal Changes:

Description

When using MySQL backend with the wrong collation the following warning are produced and it's likely that DB is created wrong. But Trac doesn't stop or bring attention to the warning. It should fail with a hint to convert MySQL table to UTF-8 collation as described in MySqlDb.

Creating and Initializing Project
 Installing default wiki pages
 /home/t/lib/python2.3/site-packages/Trac-0.11b1-py2.3.egg/trac/wiki/default-pages/TracBackup imported from TracBackup
/home/t/lib/python2.3/site-packages/Trac-0.11b1-py2.3.egg/trac/db/util.py:50: Warning: Data truncated for column 'text' at row 1
  return self.cursor.execute(sql_escape_percent(sql), args)
 /home/t/lib/python2.3/site-packages/Trac-0.11b1-py2.3.egg/trac/wiki/default-pages/TracInstall imported from TracInstall
...
 /home/t/lib/python2.3/site-packages/Trac-0.11b1-py2.3.egg/trac/wiki/default-pages/TracIni imported from TracIni
/home/t/lib/python2.3/site-packages/Trac-0.11b1-py2.3.egg/trac/db/util.py:50: Warning: Data truncated for column 'text' at row 0
  return self.cursor.execute(sql_escape_percent(sql), args)
 /home/t/lib/python2.3/site-packages/Trac-0.11b1-py2.3.egg/trac/wiki/default-pages/TracFastCgi imported from TracFastCgi
...
 Indexing repository
/home/t/lib/python2.3/site-packages/Trac-0.11b1-py2.3.egg/trac/db/util.py:50: Warning: Data truncated for column 'message' at row 1
  return self.cursor.execute(sql_escape_percent(sql), args)
 [1406]

Attachments (0)

Change History (6)

comment:1 by Emmanuel Blot, 15 years ago

Keywords: mysql added

comment:2 by Remy Blank, 14 years ago

Milestone: 1.0

comment:3 by Christian Boos, 13 years ago

Milestone: 1.0unscheduled

Milestone 1.0 deleted

comment:4 by Thijs Triemstra, 12 years ago

Cc: Thijs Triemstra added
Severity: normalmajor
Summary: trac-admin allows to init environment with errorstrac-admin allows to init environment with mysql errors

comment:5 by Thijs Triemstra, 12 years ago

Also see #8089

comment:6 by Thijs Triemstra, 12 years ago

Milestone: unscheduled
Resolution: worksforme
Status: newclosed

Not able to reproduce this with 0.13 trunk, marking it as worksforme.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Christopher Lenz.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Christopher Lenz to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.