Edgewall Software
Modify

Opened 15 years ago

Closed 14 years ago

Last modified 14 years ago

#646 closed enhancement (duplicate)

Feature request: BackLinks support in the Wiki

Reported by: Petri Savolainen / first dot last at iki dot fi Owned by: Christian Boos
Priority: normal Milestone:
Component: wiki system Version: devel
Severity: normal Keywords: BackLinks, WikiBadge
Cc: Branch:
Release Notes:
API Changes:

Description

Some Wikis support the notion of BackLinks, ie. mechanism that allows listing all wiki pages that link to the page you're currently viewing. BackLinks feature also makes possible a notion called WikiBadges, which is essentially an use pattern which introduces categorization of wiki pages using a common WikiName (=category name) written on them.

Attachments (0)

Change History (9)

comment:1 by mario at ruggier dot org, 15 years ago

I would very much like to see some kind of categorization of wiki pages, that can then be used when browsing wiki pages. Only one category per wiki page should be allowed, thus making a hierarchical listing of all wiki pages possible. I propose two explicit fields be added to wiki pages:

  • category: the single value defines the category, and should be a wiki page itself. An "Up" link can therefore be automatically added to each wiki page, as well as a list of links to other sibling pages.
  • keywords: same as for tickets, but this list of manually chosen keywords can serve not only for searching and grouping, but also to automatically generate a "See also" list of links at the bottom of a page, listing all other pages that share 1 or more of the keywords.

comment:2 by boris@…, 15 years ago

+1 for BackLinks; categories might be interesting, but the key feature would be to easily be able to add some template code that displays all the BackLinks

comment:3 by daniel, 15 years ago

Milestone: Someday

comment:4 by anonymous, 15 years ago

Regarding the BackLinks feature see also #611 where someone is volunteering to help out

comment:5 by anonymous, 15 years ago

Note that BackLinks in Trac are different from usual wiki engines:

  • Back links should include all objects that refer to current object (e.g. back links for a wiki page could include other wiki pages, tickets, change sets, etc);
  • Back links can be requested for any Trac object: wiki page, change set, source file, report, ticket, milestone, query, etc.

A typical question from wiki world "Show me all pages that are referred to my page" is translated into "Show me all objects that are referred to currently open object".

Thus, the feature looks like an enhancement for search system component.

comment:6 by Christian Boos, 14 years ago

Milestone: 0.9
Owner: changed from Jonas Borgström to Christian Boos
Status: newassigned

I can't agree more with the previous comment: it's precisely what I implemented with the TracCrossReferences

(hm, did I wrote that comment as anonymous, no, I don't think so)

comment:7 by Christopher Lenz, 14 years ago

So isn't this a duplicate of #611?

comment:8 by Christian Boos, 14 years ago

Resolution: duplicate
Status: assignedclosed

Yes of course, I was a bit too much enthusiastic :)

comment:9 by Matthew Good, 14 years ago

Milestone: 0.9

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Christian Boos.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Christian Boos to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.