Edgewall Software
Modify

Opened 12 years ago

Closed 12 years ago

#6328 closed enhancement (duplicate)

Ticket not yet specified

Reported by: daniel.oconnor@… Owned by: Jonas Borgström
Priority: normal Milestone:
Component: ticket system Version:
Severity: minor Keywords:
Cc: Branch:
Release Notes:
API Changes:

Description

Scenario: I'm coverting a business requirements document from management-speak to something developers can handle.

There are a lot of terse, tangled requirements, like "Add a postbox to the front lawn of the house"; which implies that we've built a Lawn, House, put the Lawn at the Front of the House, built a Postbox, and we're now ready to place it.

I only want to ticket one issue, place-the-postbox.

Current workflow:

  • Create original meta-ticket (all requirements)
  • Flesh out subticket (make a lawn)
  • Link to subticket on master ticket
  • Link to master ticket on subticket
  • Rinse & Repeat (make a house, place lawn infront of house, etc etc)

Proposed:

  • A macro/page processor which allows you to defer documenting tickets until later - it creates 'stubs'

IE:

  • You do a several "ticket:new" macros on the master ticket
  • When you save
    1. new blank tickets are created ("title=To Be Described")
    2. the ticket:new are replaced with the actual ticket number
  • Each new ticket has a link back to the master
  • All you do now is click through and edit the subtickets

Attachments (0)

Change History (2)

comment:1 by sid, 12 years ago

#886 addresses the master ticket concept, and although I think your idea is an interesting one, the approach addresses the root problem from the side. #886 seems to address the real problem. I propose closing as a duplicate of that ticket, and I encourage you to join in the discussion on #886.

comment:2 by daniel.oconnor@…, 12 years ago

Resolution: duplicate
Status: newclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.