Edgewall Software
Modify

Opened 13 years ago

Closed 11 years ago

Last modified 11 years ago

#6306 closed defect (duplicate)

Wrong functionality for always_update_updater ?

Reported by: kirean@… Owned by: Emmanuel Blot
Priority: normal Milestone:
Component: notification Version:
Severity: normal Keywords: notification always_notify_updater documentation
Cc: dirk.moebius@… Branch:
Release Notes:
API Changes:
Internal Changes:

Description

Hi

Not sure whether this is a defect or an enhancement request.

On wiki:0.11/TracIni, always_notify_updater has the following description:

always_notify_updaterAlways send notifications to the person who causes the ticket property change.

The effect of always_notify_updater is though that all persons which ever commented on a ticket gets the notifications.

I am changing the description on wiki:0.11/TracIni now, but I would like the possibility to have the functionality described in the original description, i.e. get notifications when commenting on a ticket.

Should we have something like always_notify_updater and always_notify_updaters where always_notify_updater really does what's described and always_notify_updaters does what always_notify_updater currently does?

Also see: #4426, comment:ticket:153:24

Attachments (1)

notification.py.patch (1.6 KB ) - added by anonymous 13 years ago.

Download all attachments as: .zip

Change History (11)

comment:1 by anonymous, 13 years ago

Component: generalnotification
Owner: changed from Jonas Borgström to Emmanuel Blot

comment:2 by kirean@…, 13 years ago

I'm not sure on how to update this information since the wiki:0.11/TracIni is using the TracIni-macro.

comment:3 by Christian Boos, 13 years ago

Just add a == Suggested Updates == section there.

comment:4 by sid, 13 years ago

Keywords: documentation added

comment:5 by anonymous, 13 years ago

Cc: dirk.moebius@… added

+1 I'd like to see this enhancement with always_notify_updater and always_notify_updaters

by anonymous, 13 years ago

Attachment: notification.py.patch added

comment:6 by anonymous, 13 years ago

Here is a patch that does just this. Although it does break backward compatibility a bit, it would be trivial to change 'always_notify_updaters' back to 'always_notify_updater' and change 'always_notify_updater' to 'always_notify_current_updater'…

comment:7 by anonymous, 12 years ago

Suggestion to avoid the BC issue:

have always_notify_updaters be one of 'true','false','always_notify_updater'. If its 'always_notfy_updater', then it uses the value of always_notify_updater, and of course, that would be the default.

If I'm understanding this properly,

always_notify_updater=false
always_notify_updaters=true

would not send a notification to the person that just submitted the change, but it would send a notification to everyone else who has ever commented on the ticket.

This, IMHO, would be a nice behaviour - I don't need to see the change that I just did, but I do care if someone further updates that ticket.

comment:8 by Remy Blank, 12 years ago

Milestone: 1.0

comment:9 by Sebastian Krysmanski <sebastian@…>, 11 years ago

Resolution: duplicate
Status: newclosed

This is a duplicate of tickets #8287 (changed description) and #2247 (patch provided to fix the self notification problem).

comment:10 by Christian Boos, 11 years ago

Milestone: 1.0

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Emmanuel Blot.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Emmanuel Blot to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.