Edgewall Software
Modify

Opened 12 years ago

Closed 11 years ago

#6303 closed defect (duplicate)

bug: ticket type names

Reported by: viko Owned by: Remy Blank
Priority: low Milestone:
Component: ticket system Version:
Severity: minor Keywords: needinfo
Cc: Branch:
Release Notes:
API Changes:

Description

when trailing the type name with a slash, trac tells there is no type with the given name, cause it cuts the trailing slash out of the url, by adding this one manually, it fits and recognizes the ticket type

Attachments (0)

Change History (4)

comment:1 by sid, 12 years ago

Keywords: needinfo added

Can you just avoid using slashes in the ticket type? Is there a use case you can give where it is important to use the slashes?

comment:2 by osimons, 12 years ago

This would be if you create a ticket type named withslash/, and then try to edit it? I see that too, and likely that will be the same for all such admin panels.

If you do the same for a wiki page, you won't be able to create the page with a trailing '/' as it gets stripped off before the Describe MyNewPage here. create page.

Is it important to support trailing '/' for values? Or, do we need to strip it off so that they do not get created like that?

comment:3 by osimons, 11 years ago

Owner: changed from Jonas Borgström to Remy Blank

There has recently been some discussion related to this at trac-dev mailing list, so reassigning to rblank that has been looking into url matching. Hope neither current nor future ticket owner minds :-)

comment:4 by Remy Blank, 11 years ago

Resolution: duplicate
Status: newclosed

Good catch, this is a duplicate of #7617.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Remy Blank.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Remy Blank to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.