Edgewall Software
Modify

Opened 15 years ago

Closed 15 years ago

Last modified 7 years ago

#613 closed defect (duplicate)

RSS feed crash when no ticket is present in the desired report in RSS format

Reported by: trac@… Owned by: daniel
Priority: normal Milestone:
Component: report system Version: 0.7.1
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:

Description

RSS feed crash when no ticket is present in the desired report in RSS format

Oops...

Trac detected an internal error:

'NoneType' object has no attribute 'child'
Traceback (most recent call last):
  File "C:\Python23\lib\site-packages\trac\core.py", line 476, in cgi_start
    real_cgi_start()
  File "C:\Python23\lib\site-packages\trac\core.py", line 471, in real_cgi_start
    dispatch_request(path_info, args, req, env, database)
  File "C:\Python23\lib\site-packages\trac\core.py", line 381, in dispatch_request
    module.run()
  File "C:\Python23\Lib\site-packages\trac\Module.py", line 42, in run
    disp()
  File "C:\Python23\lib\site-packages\trac\Report.py", line 373, in display_rss
    item = item.child()
AttributeError: 'NoneType' object has no attribute 'child'

Attachments (0)

Change History (4)

comment:1 by daniel, 15 years ago

Milestone: 0.8

comment:2 by daniel, 15 years ago

Status: newassigned

comment:3 by daniel, 15 years ago

Resolution: duplicate
Status: assignedclosed

This is a dupe of #501, and was fixed in [799].

comment:4 by Christian Boos, 7 years ago

Milestone: 0.8

(clearing report:35)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain daniel.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from daniel to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.