Edgewall Software
Modify

Opened 12 years ago

Closed 12 years ago

#6126 closed defect (duplicate)

Internal error when trying to save kn_IN letters

Reported by: vincentvikram@… Owned by: Jonas Borgström
Priority: normal Milestone:
Component: general Version: 0.10.3
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:

Description (last modified by Emmanuel Blot)

Steps to reproduce the error:

  1. I tried to save a section which had a kn_IN script characters and obtained the below error.
  2. Removed the offending language characters and the content was saved.
  3. Tried to paste the characters here and the bug report reported a bug :)

Error Reproducible.

Traceback (most recent call last):
  File "/var/lib/python-support/python2.4/trac/web/main.py", line 387, in dispatch_request
    dispatcher.dispatch(req)
  File "/var/lib/python-support/python2.4/trac/web/main.py", line 237, in dispatch
    resp = chosen_handler.process_request(req)
  File "/var/lib/python-support/python2.4/trac/wiki/web_ui.py", line 113, in process_request
    self._do_save(req, db, page)
  File "/var/lib/python-support/python2.4/trac/wiki/web_ui.py", line 239, in _do_save
    req.remote_addr)
  File "/var/lib/python-support/python2.4/trac/wiki/model.py", line 126, in save
    "%s,%s)", (self.name, self.version + 1, t, author,
  File "/var/lib/python-support/python2.4/trac/db/util.py", line 50, in execute
    return self.cursor.execute(sql_escape_percent(sql), args)
  File "/var/lib/python-support/python2.4/trac/db/util.py", line 50, in execute
    return self.cursor.execute(sql_escape_percent(sql), args)
ProgrammingError: character 0xe0b297 of encoding "UNICODE" has no equivalent in "LATIN1"

Attachments (1)

offending_characters_example (20 bytes ) - added by vincentvikram@… 12 years ago.
Example of characters(kn_IN) causing error.

Download all attachments as: .zip

Change History (2)

by vincentvikram@…, 12 years ago

Example of characters(kn_IN) causing error.

comment:1 by Emmanuel Blot, 12 years ago

Description: modified (diff)
Resolution: duplicate
Status: newclosed

Duplicate of #6125 (submitted twice)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.