Edgewall Software
Modify

Opened 14 years ago

Closed 14 years ago

#6108 closed defect (worksforme)

Can't cut text with Konqueror in textareas

Reported by: dirk Owned by: Jonas Borgström
Priority: normal Milestone:
Component: general Version: 0.10.4
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

The Ctrl+X shortcut is broken in Konqueror (using version 3.5.7).

Steps:

  • Enter something into a textarea (wiki or new ticket for example).
  • Mark some text (with mouse or keyboard).
  • Ctrl+X to cut the text.
  • Text isn't cut. Instead the text is unmarked and the focus is set to the beginning of the marker.

This makes Trac very hard to use in Konqueror. I would expect that the text is cut into the clipboard like it is in Firefox.

Attachments (0)

Change History (4)

comment:1 by sid, 14 years ago

Is this specific to Trac or does this happen on other websites as well?

comment:2 by anonymous, 14 years ago

Keywords: needinfo added

in reply to:  1 comment:3 by anonymous, 14 years ago

Replying to sid:

Is this specific to Trac or does this happen on other websites as well?

It only happens with Trac. I've narrowed down the source of the problem to wikitoolbar.js. When the script is removed, text can be cut normally.

comment:4 by Christian Boos, 14 years ago

Keywords: needinfo removed
Resolution: worksforme
Status: newclosed

Assuming this works now with newer versions of Konqueror.

If not, feel free to reopen.

Written using Konqueror 3.2.1, where the problem is not present (and neither is the wiki toolbar, one thing which may explain the other ;-) ).

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.