Edgewall Software
Modify

Opened 12 years ago

Closed 12 years ago

#6029 closed defect (worksforme)

AssertionError:

Reported by: b.huijts@… Owned by: Jonas Borgström
Priority: normal Milestone:
Component: general Version: devel
Severity: normal Keywords: needinfo
Cc: Branch:
Release Notes:
API Changes:

Description

How to Reproduce

While doing a GET operation on /ticket/2, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'id': u'2'}

System Information

Trac 0.11dev-r6011
Python 2.4.4 (#1, Apr 5 2007, 20:09:06)
[GCC 4.1.2 20061115 (prerelease) (Debian 4.1.1-21)]
setuptools 0.6c7
SQLite 3.3.8
pysqlite 2.3.2
Genshi 0.4.4

Python Traceback

Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/Trac-0.11dev_r6011-py2.4.egg/trac/web/main.py", line 381, in dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.4/site-packages/Trac-0.11dev_r6011-py2.4.egg/trac/web/main.py", line 191, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/lib/python2.4/site-packages/Trac-0.11dev_r6011-py2.4.egg/trac/ticket/web_ui.py", line 145, in process_request
    return self._process_ticket_request(req)
  File "/usr/lib/python2.4/site-packages/Trac-0.11dev_r6011-py2.4.egg/trac/ticket/web_ui.py", line 443, in _process_ticket_request
    field_changes)
  File "/usr/lib/python2.4/site-packages/Trac-0.11dev_r6011-py2.4.egg/trac/ticket/web_ui.py", line 1044, in _insert_ticket_data
    label, widget, hint = controller.render_ticket_action_control(
  File "/usr/lib/python2.4/site-packages/Trac-0.11dev_r6011-py2.4.egg/trac/ticket/default_workflow.py", line 238, in render_ticket_action_control
    assert(resolutions)
AssertionError

Attachments (0)

Change History (2)

comment:1 by Christian Boos, 12 years ago

Keywords: needinfo added

Well, did you remove all the entries for the resolution enum, in the trac db?

comment:2 by sid, 12 years ago

Resolution: worksforme
Status: newclosed

Closing due to lack of response. Please reopen if you have more information to add to the ticket. Thanks!

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.