Edgewall Software
Modify

Opened 12 years ago

Closed 12 years ago

#6010 closed defect (duplicate)

My custom query that used to work now gives me a python dump

Reported by: jason@… Owned by: Matthew Good
Priority: normal Milestone:
Component: report system Version:
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:

Description (last modified by Emmanuel Blot)

I made a custom query: http://trac.tokbox.com/trac.cgi/tokbox/query?status=new&status=assigned&status=reopened&group=milestone&owner=%7Ejason&order=priority

Which worked fine until I marked a ticket as invalid, at which point I got this error:
Traceback (most recent call last):
  File "/var/lib/python-support/python2.5/trac/web/main.py", line 387, in dispatch_request
    dispatcher.dispatch(req)
  File "/var/lib/python-support/python2.5/trac/web/main.py", line 237, in dispatch
    resp = chosen_handler.process_request(req)
  File "/var/lib/python-support/python2.5/trac/ticket/query.py", line 443, in process_request
    self.display_html(req, query)
  File "/var/lib/python-support/python2.5/trac/ticket/query.py", line 608, in display_html
    req.hdf['query.num_matches_group'] = num_matches_group
  File "/var/lib/python-support/python2.5/trac/web/clearsilver.py", line 197, in __setitem__
    self.set_value(name, value, True)
  File "/var/lib/python-support/python2.5/trac/web/clearsilver.py", line 245, in set_value
    add_value(name, value)
  File "/var/lib/python-support/python2.5/trac/web/clearsilver.py", line 237, in add_value
    add_value('%s.%s' % (prefix, k), value[k])
  File "/var/lib/python-support/python2.5/trac/web/clearsilver.py", line 221, in add_value
    set_str(prefix, int(value))
  File "/var/lib/python-support/python2.5/trac/web/clearsilver.py", line 215, in set_str
    self.hdf.setValue(prefix.encode('utf-8'), str(value))
Error: Traceback (innermost last):
  File "neo_hdf.c", line 805, in hdf_set_value()
  File "neo_hdf.c", line 795, in _set_value()
AssertError: Unable to set Empty component query.num_matches_group.

Attachments (0)

Change History (2)

comment:1 by Emmanuel Blot, 12 years ago

Component: ticket systemreport system
Description: modified (diff)
Keywords: needinfo added
Owner: changed from Jonas Borgström to Matthew Good

The above URL is not available without a login/password.

Please provide useful details, such as the Trac version

comment:2 by Christian Boos, 12 years ago

Keywords: needinfo removed
Resolution: duplicate
Status: newclosed

Please upgrade to milestone:0.10.4, this bug has been fixed.

(he he manu, you missed an easy duplicate of #4218 here ;-) )

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Matthew Good.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Matthew Good to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.