Edgewall Software
Modify

Opened 12 years ago

Closed 12 years ago

#5897 closed defect (duplicate)

Milestone name change doesn't reflect in ticket_change table

Reported by: khundeen@… Owned by: Christopher Lenz
Priority: normal Milestone:
Component: roadmap Version:
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:

Description

When changing a milestone's name, the milestone name in ticket_change table wasn't changed.

This cause problem when analyzing the ticket changelog again the milestone whose name was changed. It would be great to change the milestone name to the new one when milestone name is changed.

Attachments (0)

Change History (3)

comment:1 by Christian Boos, 12 years ago

Milestone: 0.12

See also #5658.

comment:2 by mape <th07@…>, 12 years ago

I think this is problem in general in the db schema: names are used to link rather than unique ids. Name approach may shorten SQL & make it more readable, but it causes problems like this.

I'm quite sure that using webadmin to change milestones or components will have the same problem.

comment:3 by osimons, 12 years ago

Milestone: 0.12
Resolution: duplicate
Status: newclosed

Closing this one as a duplicate of #4582.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Christopher Lenz.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Christopher Lenz to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.