Edgewall Software
Modify

Opened 15 years ago

Closed 15 years ago

Last modified 7 years ago

#550 closed defect (invalid)

Following intra trac link to non-existent revision causes error

Reported by: sean.ohalpin@… Owned by: Jonas Borgström
Priority: highest Milestone:
Component: wiki system Version: 0.7.1
Severity: blocker Keywords: Intra Trac Links
Cc: Branch:
Release Notes:
API Changes:

Description

Following intra trac link to non-existent revision causes error

After installing, clicking on the example intra trac link in WikiFormatting to a specific file revision - source:/trunk/COPYING#200 - (which does not exist in my repository) causes the following error:

null argument to internal routine

Python traceback

Traceback (most recent call last):
  File "C:\Python23\lib\site-packages\trac\core.py", line 475, in cgi_start
    real_cgi_start()
  File "C:\Python23\lib\site-packages\trac\core.py", line 470, in real_cgi_start
    dispatch_request(path_info, args, req, env, database)
  File "C:\Python23\lib\site-packages\trac\core.py", line 380, in dispatch_request
    module.run()
  File "C:\Python23\lib\site-packages\trac\Module.py", line 41, in run
    self.render()
  File "C:\Python23\lib\site-packages\trac\Browser.py", line 156, in render
    info = self.get_info(path, rev, rev_specified)
  File "C:\Python23\lib\site-packages\trac\Browser.py", line 39, in get_info
    root = fs.revision_root(self.fs_ptr, revision, self.pool)
SystemError: null argument to internal routine

Attachments (0)

Change History (6)

comment:1 by Jonas Borgström, 15 years ago

Milestone: 0.8
Severity: normaltrivial

comment:2 by anonymous, 15 years ago

Priority: normalhighest
Severity: trivialblocker

comment:3 by Jonas Borgström, 15 years ago

I'm not able to reproduce this with trunk… anyone?

comment:4 by arnaud at ak-family.net, 15 years ago

I wasn't able to reproduce it, even on my 0.7 trac version. I have a nice error message telling me there's no file or directory with that name in the version I'm querying…

comment:5 by Jonas Borgström, 15 years ago

Resolution: invalid
Status: newclosed

Ok, closing this ticket then…

comment:6 by Christian Boos, 7 years ago

Milestone: 0.8

(clearing report:35)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.