Edgewall Software
Modify

Opened 12 years ago

Closed 12 years ago

#5485 closed defect (duplicate)

Error when trying to add an attachment to a ticket

Reported by: rohan@… Owned by: Matthew Good
Priority: low Milestone:
Component: plugin/spamfilter Version: 0.10.3
Severity: normal Keywords: attachment
Cc: Branch:
Release Notes:
API Changes:

Description (last modified by Emmanuel Blot)

Steps:

  1. Tried to add an html file attachement. Denied due to "number of external links" exceeded (spam).
  2. Zipped the html file and hit "back" to try and add the attachment as a zip file.

The following error appeared:

Python Traceback
Traceback (most recent call last):
  File "/home/trac/new-djangoproject-trac-test/trac/web/main.py", line 387, in dispatch_request
  File "/home/trac/new-djangoproject-trac-test/trac/web/main.py", line 237, in dispatch
  File "/home/trac/new-djangoproject-trac-test/trac/attachment.py", line 361, in process_request
  File "/home/trac/new-djangoproject-trac-test/trac/attachment.py", line 475, in _do_save
  File "build/bdist.linux-i686/egg/tracspamfilter/adapters.py", line 130, in validate_attachment
  File "build/bdist.linux-i686/egg/tracspamfilter/api.py", line 131, in test
  File "build/bdist.linux-i686/egg/tracspamfilter/model.py", line 119, in insert
  File "/home/trac/new-djangoproject-trac-test/trac/db/util.py", line 50, in execute
  File "/home/trac/new-djangoproject-trac-test/trac/db/util.py", line 50, in execute
  File "/usr/lib/python2.3/site-packages/pyPgSQL/PgSQL.py", line 3083, in execute
    parms = _quoteall(self.__unicodeConvert(parms[0]))
  File "/usr/lib/python2.3/site-packages/pyPgSQL/PgSQL.py", line 2300, in _quoteall
    t = tuple(map(_quote, vdict))
  File "/usr/lib/python2.3/site-packages/pyPgSQL/PgSQL.py", line 2268, in _quote
    return PgQuoteString(value)
TypeError: PgQuoteString() argument 1 must be string without null bytes, not str

Attachments (0)

Change History (4)

comment:1 by Emmanuel Blot, 12 years ago

Component: ticket systemspamfilter
Description: modified (diff)
Owner: changed from Jonas Borgström to Matthew Good

On which version of Trac did this error occur?

comment:2 by Rohan, 12 years ago

The problem occured as an end-user of a Trac installation, so I don't know what version it is, but here's the URL of the installation:

http://code.djangoproject.com/simpleticket

comment:3 by Emmanuel Blot, 12 years ago

Version: 0.10.3

Ok, so this is a 0.10.3 installation.

comment:4 by Emmanuel Blot, 12 years ago

Resolution: duplicate
Status: newclosed

Likely to be a duplicate of #5061 and finally #4087.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Matthew Good.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Matthew Good to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.