Edgewall Software
Modify

Opened 13 years ago

Closed 13 years ago

#5468 closed defect (duplicate)

Having connection problem with Trac

Reported by: shanski21@… Owned by: Jonas Borgström
Priority: normal Milestone:
Component: general Version:
Severity: blocker Keywords:
Cc: Branch:
Release Notes:
API Changes:

Description

Python Traceback

Traceback (most recent call last):

File "C:\Python24\lib\site-packages\trac\web\main.py", line 387, in dispatch_request

dispatcher.dispatch(req)

File "C:\Python24\lib\site-packages\trac\web\main.py", line 191, in dispatch

chosen_handler = self._pre_process_request(req, chosen_handler)

File "C:\Python24\lib\site-packages\trac\web\main.py", line 263, in _pre_process_request

chosen_handler = f.pre_process_request(req, chosen_handler)

File "C:\Python24\lib\site-packages\trac\versioncontrol\api.py", line 73, in pre_process_request

self.get_repository(req.authname) # triggers a sync if applicable

File "C:\Python24\lib\site-packages\trac\versioncontrol\api.py", line 101, in get_repository

repos = self._connector.get_repository(rtype, rdir, authname)

File "C:\Python24\lib\site-packages\trac\versioncontrol\svn_fs.py", line 260, in get_repository

crepos = CachedRepository(self.env.get_db_cnx(), repos, None, self.log)

File "C:\Python24\lib\site-packages\trac\versioncontrol\cache.py", line 34, in init

self.sync()

File "C:\Python24\lib\site-packages\trac\versioncontrol\cache.py", line 53, in sync

cursor = self.db.cursor()

File "C:\Python24\lib\site-packages\trac\db\util.py", line 78, in cursor

return IterableCursor(self.cnx.cursor())

File "C:\Python24\lib\site-packages\trac\db\util.py", line 78, in cursor

return IterableCursor(self.cnx.cursor())

File "C:\Python24\lib\site-packages\pyPgSQL\PgSQL.py", line 2599, in cursor

return Cursor(self, name, isRefCursor)

File "C:\Python24\lib\site-packages\pyPgSQL\PgSQL.py", line 2718, in init

self.conn._ConnectionsetupTransaction()

File "C:\Python24\lib\site-packages\pyPgSQL\PgSQL.py", line 2510, in setupTransaction

self.conn.query("BEGIN WORK")

OperationalError: no connection to the server

Attachments (0)

Change History (1)

comment:1 by markus, 13 years ago

Resolution: duplicate
Status: newclosed

Duplicate of #5358.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.