Edgewall Software
Modify

Opened 13 years ago

Closed 13 years ago

#5356 closed defect (duplicate)

Notification Problem in Trac

Reported by: shelly@… Owned by: Jonas Borgström
Priority: normal Milestone:
Component: notification Version:
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:

Description

I'm running trac 0.10.3.1 on a RHEL 4 update 5 system. I'm using Apache 2.0.52.

Apache authenticates using Kerberos, meaning Trac login names (logged in as) are in the form username@…. The user goes into Settings and enters their username and email address in the appropriate fields.

Trac is configured for email. Here the relevant bits from the trac.ini file:

[notification] always_notify_owner = true always_notify_reporter = true always_notify_updater = true smtp_always_bcc = smtp_always_cc = smtp_default_domain = smtp_enabled = true smtp_from = name@example smtp_password = smtp_port = 25 smtp_replyto = n...@… smtp_server = localhost smtp_user = use_short_addr = true

When the user creates and saves a new ticket or makes changes to existing tickets, email is being set to username@… instead of to the email address listed in settings. Needless to say, email is not getting to the user.

Oh, and it would be nice if the "Logged in as" displayed the Name field from Settings instead of username@….

I see there are patches for both issues in version 0.9.X, but neither appear to work in 0.10.3.

Thanks, Shelly

Attachments (0)

Change History (1)

in reply to:  description comment:1 by Emmanuel Blot, 13 years ago

Component: generalnotification
Resolution: duplicate
Status: newclosed

Replying to shelly@pnl.gov:

I see there are patches for both issues in version 0.9.X, but neither appear to work in 0.10.3.

Please not create duplicate of existing tickets.

Duplicate of #2766.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.