Edgewall Software
Modify

Opened 15 years ago

Closed 15 years ago

Last modified 8 years ago

#5336 closed defect (worksforme)

Premature end of script headers: trac.cgi

Reported by: divil@… Owned by: Jonas Borgström
Priority: normal Milestone:
Component: general Version: 0.10.4
Severity: normal Keywords: needinfo
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

hello,

trac stopped working for me.

calling my trac-page is giving me:

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, root and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

error_log is giving me:

[error] [client myip] Premature end of script headers: trac.cgi

acces_log gives me:

[19/May/2007:18:52:30 +0200] "GET /cgi-bin/trac.cgi HTTP/1.1" 500 534

i tried to replace the trac.db with a backup and resync it with svn - but this results in a segementation fault

any help/hint would be appreciated!

Attachments (0)

Change History (5)

in reply to:  description comment:1 by Emmanuel Blot, 15 years ago

Keywords: needinfo added

Replying to divil@gmx.at:

trac stopped working for me.

Does it mean that it used to work before … something?

Did you upgrade?

It looks like an environment/installation issue, I would suggest you first ask for support on the MailingList.

comment:2 by sid, 15 years ago

Resolution: worksforme
Status: newclosed

Closing due to lack of information.

comment:3 by mat_the_green@…, 15 years ago

Resolution: worksforme
Severity: normalblocker
Status: closedreopened
Version: 0.10.3.10.10.4

I orginally installed trac using Ubuntu apt-get package following these installation guidelines with a postgreSQL db. Trac was working well and I was starting to ad the maven, cruisecontrol and trail plugins but they failed to work as I needed trac version 0.10. So I upgraded the trac libaray with the python/site-packages and stopped working. I then realised that I needed to upgrade my environment but still did not work, so a create a freash project but still did not work.

Hopefully this can be fixed or some more nice instructions, as found for the Ubuntu install, explaining how to upgrade step by step for us linux newbies.

comment:4 by Emmanuel Blot, 15 years ago

Severity: blockernormal

comment:5 by Emmanuel Blot, 15 years ago

Resolution: worksforme
Status: reopenedclosed

You need to start from a fresh Trac install (using 0.10.4), without any plugin:

  • If the issue comes from a plugin, please contact the plugin maintainer
  • If the issue comes from the Ubuntu package, please contact the package maintainer. Distribution-related issue should be addressed by the distribution maintainer.

You may also want to post an email to the MailingList and check whether other Ubuntu users have encountered the same issue.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.