Edgewall Software
Modify

Opened 14 years ago

Closed 13 years ago

Last modified 11 years ago

#529 closed defect (duplicate)

IE 5-6 over HTTPS broken downloads

Reported by: tiger@… Owned by: Jonas Borgström
Priority: low Milestone:
Component: general Version: 0.7
Severity: major Keywords: windows iexplorer
Cc:
Release Notes:
API Changes:

Description

It is known bug of the IE (only) over HTTPS that if any cache control headers were sent before content transfer (specifically file download) then it causes IE error message (can't write to cache - bla-bla-bla) and file download gets aborted. Moreover, as it also known, the HTTPS could not be cached so cache-control headers are useless under HTTPS IMHO. So I propose to check the the env HTTPS (for example) to decide whether to send cache-control headers or not. Specifically current workaround is to comment out sending cache-control everywhere in code under HTTPS.

Attachments (0)

Change History (7)

comment:1 Changed 13 years ago by anonymous

Summary: IE 5-7 over HTTPS broken downloadsIE 5-6 over HTTPS broken downloads

comment:2 Changed 13 years ago by daniel

Milestone: 0.8

comment:3 Changed 13 years ago by Jonas Borgström

Is this IE bug present in the latest IE version, that is, will this problem go away by itself when people upgrade their browsers?

comment:4 Changed 13 years ago by daniel

Keywords: windows ie added
Milestone: 0.80.9
Priority: highlow

comment:5 Changed 13 years ago by Christopher Lenz

Resolution: duplicate
Status: newclosed

Duplicate of #1020.

comment:6 Changed 12 years ago by Matthew Good

Milestone: 0.9

comment:7 Changed 11 years ago by sid

Keywords: iexplorer added; ie removed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted.
to The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .

 
Note: See TracTickets for help on using tickets.