Edgewall Software
Modify

Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#5226 closed defect (worksforme)

Unable to upload/download attachments w/ Safari

Reported by: synfinatic@… Owned by: Jonas Borgström
Priority: normal Milestone:
Component: general Version: 0.10.4
Severity: normal Keywords: attachments safari needinfo
Cc: dpeckham@… Branch:
Release Notes:
API Changes:

Description

Using Safari 2.0.4 (419.3) under OS X 10.4.9, I'm unable to upload or download attachments. When uploading a file, the submission seems to hang, returning a timeout error. Downloading binary attachments (like gziped files) causes Safari to download the webpage download screen, not the file itself.

Attachments (4)

testing.txt (7 bytes ) - added by sid 12 years ago.
test file uploaded using Safari
Picture 8.png (40.6 KB ) - added by anonymous 12 years ago.
Tried with Safari 3, OS X (Intel) 10.4.10, upload to this ticket
green_apple_logo.jpg (20.6 KB ) - added by wms 12 years ago.
green_apple_logo.2.jpg (20.6 KB ) - added by wms 12 years ago.

Download all attachments as: .zip

Change History (18)

comment:1 by aljungberg at wireload.net, 12 years ago

I have encountered this problem as well. The upload hangs. The log files reveal a message as such,

… File "/usr/local/lib/python2.4/site-packages/trac/web/modpython_frontend.py", line 37, in readline\n return self.req.readline(size), referer: … IOError: Client read error (Timeout?)

The same upload works fine in Firefox.

comment:2 by lammert [at] begeleidingentraining [dot] nl, 12 years ago

I also encountered this problem, when i try to upload a file in Safari 2.0.4 (419.3) the page keeps loading for a few minutes and finally it gives an 500 Internal Server Error:

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, email@domain.ext and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

when i opened the httpd-error-log it gives the following error:

[Tue Jun 26 12:05:51 2007] [error] [client 10.1.2.42] (70007)The timeout specified has expired: Error reading request entity data, referer: https://sub.domain.ext/cgi-bin/repo/trac.cgi/attachment/wiki/WikiStart?action=new

And as the person above this message all works fine in Firefox 2.0.0.4

comment:3 by aljungberg at wireload.net, 12 years ago

This appears to have been resolved in the latest version.

by sid, 12 years ago

Attachment: testing.txt added

test file uploaded using Safari

comment:4 by sid, 12 years ago

Keywords: needinfo added

I just used Safari to upload a file fine to this ticket. Can you verify upload and download of attachments is working for you as well?

comment:5 by synfinatic@…, 12 years ago

Resolution: fixed
Status: newclosed

Works for me.

comment:6 by Emmanuel Blot, 12 years ago

Resolution: fixed
Status: closedreopened

comment:7 by Emmanuel Blot, 12 years ago

Resolution: worksforme
Status: reopenedclosed

by anonymous, 12 years ago

Attachment: Picture 8.png added

Tried with Safari 3, OS X (Intel) 10.4.10, upload to this ticket

comment:8 by anonymous, 12 years ago

Resolution: worksforme
Status: closedreopened

I am not able to upload anything to this ticket, using Safari 3 on OS X Intel 10.4.10.

We have the same issues with our internal 0.10.4 trac installation(s).

From a discussion I have had with another coworker (this may or may not be correct:

5:08:19 PM figured out the [Trac and] Safari problem 5:09:04 PM it's unable to submit an HTTP upload over a connection that is reused from the keep-alive pool, so I have to get to the file upload page and then just wait there for a minute for the kept-alive connection to expire 5:09:19 PM then I can submit and it goes through 5:10:31 PM what's more interesting is that it works for small files 5:10:37 PM it's only large files that I have this problem with

comment:9 by Dave Peckham <dpeckham@…>, 12 years ago

Cc: peckhda added

I tested this with Safari 3.0.4 and confirmed that the upload succeeds if you wait at least one minute after opening the Attachments page. It fails otherwise.

comment:10 by Dave Peckham <dpeckham@…>, 12 years ago

Cc: dpeckham@… added; peckhda removed

comment:11 by Emmanuel Blot, 12 years ago

I can't reproduce this issue w/ Safari 3.0.4 and the current trunk (using Apache 2.2 or tracd)

by wms, 12 years ago

Attachment: green_apple_logo.jpg added

by wms, 12 years ago

Attachment: green_apple_logo.2.jpg added

comment:12 by Christian Boos, 12 years ago

Resolution: worksforme
Status: reopenedclosed

Weird Safari specific issue. Works for eblot, not Dave but he gives a workaround (comment:9).

Assuming it works for recent versions of Safari. Please reopen if it's not the case (ideally, provide a patch!)

comment:13 by Dave Peckham, 12 years ago

This works for me with Safari 3.1 (525.13).

comment:14 by Christian Boos, 12 years ago

Thanks for the feedback, Dave. And now that there's a Safari build for Windows, it's part of the Web browsers I test regularly with Trac.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.