Edgewall Software
Modify

Opened 15 years ago

Closed 15 years ago

#5178 closed defect (invalid)

Trac requires re-sync after editing Wiki main page

Reported by: Brian Heylin Owned by: Christian Boos
Priority: normal Milestone:
Component: wiki system Version:
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description (last modified by Emmanuel Blot)

Was re-editing main page, was adding to the original default content. last thing i did was put spaces in front of all the '*' chars as i think this is the proper syntax for a list item? So did that and requested a preview

Ok so heres the trace back:

Traceback (most recent call last):
  File "C:\Python24\Lib\site-packages\trac\web\main.py", line 387, in dispatch_request
    dispatcher.dispatch(req)
  File "C:\Python24\Lib\site-packages\trac\web\main.py", line 191, in dispatch
    chosen_handler = self._pre_process_request(req, chosen_handler)
  File "C:\Python24\Lib\site-packages\trac\web\main.py", line 263, in _pre_process_request
    chosen_handler = f.pre_process_request(req, chosen_handler)
  File "C:\Python24\Lib\site-packages\trac\versioncontrol\api.py", line 73, in pre_process_request
    self.get_repository(req.authname) # triggers a sync if applicable
  File "C:\Python24\Lib\site-packages\trac\versioncontrol\api.py", line 101, in get_repository
    repos = self._connector.get_repository(rtype, rdir, authname)
  File "C:\Python24\Lib\site-packages\trac\versioncontrol\svn_fs.py", line 260, in get_repository
    crepos = CachedRepository(self.env.get_db_cnx(), repos, None, self.log)
  File "C:\Python24\Lib\site-packages\trac\versioncontrol\cache.py", line 34, in __init__
    self.sync()
  File "C:\Python24\Lib\site-packages\trac\versioncontrol\cache.py", line 59, in sync
    raise TracError("The 'repository_dir' has changed, "
TracError: The 'repository_dir' has changed, a 'trac-admin resync' operation is needed.

Attachments (0)

Change History (6)

comment:1 by Emmanuel Blot, 15 years ago

Description: modified (diff)
Keywords: needinfo added

Very weird indeed. Editing wiki page and SVN resync are fully unrelated.

Are you sure no one as updated the project config file (trac.ini) at the same time, or performed some maintainance on the subversion repository while you were editing the page?

BTW, please specify which version of Trac you're using. Thanks.

comment:2 by anonymous, 15 years ago

Hi, i have exact the same problem that occured when i made trunk, branch and tags folder in the projects folder using tortoise…

what do i have to do to get this resync?

comment:3 by anonymous, 15 years ago

when i do a resync i get this message:

Trac [C:\Python24\Scripts\resync]> resync Failed to open environment. [Errno 2] No such file or directory: 'C:
Python24
Scripts
resync
VERSION' Traceback (most recent call last):

File "C:\Python24\Lib\site-packages\trac\scripts\admin.py", line 134, in env_o

pen

self.env = Environment(self.envname)

File "C:\Python24\Lib\site-packages\trac\env.py", line 147, in init

self.verify()

File "C:\Python24\Lib\site-packages\trac\env.py", line 195, in verify

fd = open(os.path.join(self.path, 'VERSION'), 'r')

IOError: [Errno 2] No such file or directory: 'C:
Python24
Scripts
resync
VE RSION'

C:\Python24\Scripts>

comment:4 by anonymous, 15 years ago

Microsoft Windows XP [Version 5.1.2600] © Copyright 1985-2001 Microsoft Corp.

C:\Python24\Scripts>tracd.py usage: tracd.py [options] [projenv] …

tracd.py: error: either the —env-parent-dir option or at least one environment must be specified

Before making the 3 folders with tortoise there was no problem…

comment:5 by anonymous, 15 years ago

btw using trac 1.10.4 and the 2.4 binaries and subversion 1.4.4

in reply to:  5 comment:6 by Emmanuel Blot, 15 years ago

Keywords: needinfo removed
Resolution: invalid
Status: newclosed

Replying to anonymous:

btw using trac 1.10.4 and the 2.4 binaries and subversion 1.4.4

So that would be 0.10.4, 1.10.4 does not exist, and please use the dedicated field for indicating the Trac version. I assume that "2.4 binaries" means "Python 2.4".

anonymous: from the log messages you've posted, it looks like you get confused about how to specify a Trac environment. Please post to the MailingList, as this is not a bug in Trac but how you are trying to use it.

Closing this ticket as the original author has not provided any feedback for over 4 months.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Christian Boos.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Christian Boos to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.