Edgewall Software
Modify

Opened 15 years ago

Closed 15 years ago

#5134 closed enhancement (duplicate)

paginate report

Reported by: liris <liris.pp@…> Owned by: Jonas Borgström
Priority: normal Milestone:
Component: ticket system Version: 0.10.3.1
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

When we show the ticket reports, the html generation is too slow(abount 1min for my system) if the ticket is more than 5000. The time to spend is almost to rendering html. And if the browser gets the huge html file, the browser is also slow down.

The attached is the patch to paginate reports.

Attachments (1)

report-paginate.diff (3.6 KB ) - added by liris <liris.pp@…> 15 years ago.
paginate patch for report

Download all attachments as: .zip

Change History (3)

by liris <liris.pp@…>, 15 years ago

Attachment: report-paginate.diff added

paginate patch for report

comment:1 by liris <liris.pp@…>, 15 years ago

Version: 0.10.3.1

comment:2 by Christian Boos, 15 years ago

Resolution: duplicate
Status: newclosed

The patch modifies the clearsilver template (report.cs) of Trac 0.10.x, but there won't be any new feature enhancement on this release line, only bug fixes.

Please consider adapting your patch for Trac 0.11dev, and the report.html Genshi template. See TracDev/PortingFromClearSilverToGenshi for some hints.

The ticket itself is a duplicate of #216, please follow-up there.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.