Edgewall Software
Modify

Opened 15 years ago

Closed 15 years ago

Last modified 7 years ago

#489 closed defect (invalid)

Session cookie required when logged in

Reported by: mithrandi@… Owned by: Jonas Borgström
Priority: high Milestone:
Component: general Version: devel
Severity: blocker Keywords:
Cc: Branch:
Release Notes:
API Changes:

Description

I just checked out the trunk (r679), setup a Trac instance, and logged in from the "front page". Wiki, Timeline, and Browse Source worked fine, but Roadmap, View Tickets, New Ticket, and Search all gave me the error about "session cookie required". Clicking on the "log in and continue" link just brought me back to the same page. At this point, I checked what cookies were set, and I had both trac_auth and trac_session set, with the path pointing to the cgi. Once I filled in my details for the session (name / e-mail address), everything started working normally.

Attachments (0)

Change History (6)

comment:1 by mithrandi@…, 15 years ago

Severity: minormajor

Actually, everything isn't normal; the pages that were complaining about a session cookie now display, but Trac doesn't acknowledge that I'm logged in; I get a login button etc.

comment:2 by mithrandi@…, 15 years ago

I should probably mention that I'm using Mozilla Firefox 0.8 on Debian Sid.

comment:3 by mithrandi@…, 15 years ago

Yet more info; if I configure Apache to require auth on trac.cgi, instead of trac.cgi/login, then everything works (aside from unauthenticated access obviously being broken).

comment:4 by Christopher Lenz, 15 years ago

Milestone: 0.8
Priority: normalhigh
Severity: majorblocker

I'm seeing this problem too, and very frequently, but haven't yet been able to systematically reproduce it.

Increasing severity/priority as this is very annoying :-/

comment:5 by idnar, 15 years ago

Resolution: invalid
Status: newclosed

Turns out the problem was caused by a transparent proxy in the way; requests were coming from different IP addresses, so the auth cookie wasn't matching. I haven't experienced any problems since working around this.

comment:6 by Christian Boos, 7 years ago

Milestone: 0.8

(clearing report:35)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.