Edgewall Software
Modify

Opened 15 years ago

Closed 15 years ago

#4718 closed defect (duplicate)

error when submiting chinese characters in ticket description

Reported by: xuefer@… Owned by: Jonas Borgström
Priority: normal Milestone:
Component: plugin/spamfilter Version: 0.10.3
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

http://trac.edgewall.org/newticket

http://trac.edgewall.org/ticket/4717

Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/trac/web/main.py", line 387, in dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.4/site-packages/trac/web/main.py", line 237, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/lib/python2.4/site-packages/trac/ticket/web_ui.py", line 127, in process_request
    self._do_create(req, db)
  File "/usr/lib/python2.4/site-packages/trac/ticket/web_ui.py", line 188, in _do_create
    self._validate_ticket(req, ticket)
  File "/usr/lib/python2.4/site-packages/trac/ticket/web_ui.py", line 66, in _validate_ticket
    for field, message in manipulator.validate_ticket(req, ticket):
  File "build/bdist.linux-x86_64/egg/tracspamfilter/adapters.py", line 68, in validate_ticket
  File "build/bdist.linux-x86_64/egg/tracspamfilter/api.py", line 131, in test
  File "build/bdist.linux-x86_64/egg/tracspamfilter/model.py", line 119, in insert
  File "/usr/lib/python2.4/site-packages/trac/db/util.py", line 50, in execute
    return self.cursor.execute(sql_escape_percent(sql), args)
  File "/usr/lib/python2.4/site-packages/trac/db/util.py", line 50, in execute
    return self.cursor.execute(sql_escape_percent(sql), args)
ProgrammingError: current transaction is aborted, commands ignored until end of transaction block

Attachments (0)

Change History (2)

comment:1 by Christian Boos, 15 years ago

This is a duplicate of #4087.

comment:2 by Christian Boos, 15 years ago

Component: ticket systemspamfilter
Milestone: 0.10.4
Resolution: duplicate
Status: newclosed

(forgot to actually close the ticket)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.