Edgewall Software
Modify

Opened 13 years ago

Closed 13 years ago

#4643 closed enhancement (duplicate)

ability to specify when custom fields should show up based on ticket type

Reported by: eoin.dunne@… Owned by: Jonas Borgström
Priority: normal Milestone:
Component: general Version:
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:

Description

We've added a couple of custom ticket types. The flexibility of this is awsome. The only short coming is that the ticket form can start to get clutered. The other thing is sometimes custom fields only make sense for certain types of tickets.

For example, we added a support_call ticket type. There is another system that we tie so we created a custom text field where support can enter a reference (issue number), to another internal system we have.

The only thing is that this field only makes sense in the context of the support_call ticket type. If you could add a constraint to the trac.ini configuration section for that custom field, perhaps a list of ticket types when the custom field should appear.

something like:

customFieldName.show=support_call customFieldName.show=all or to show the field in a subset of ticket types… customFieldName.show=defect, enhancement, support_call

Attachments (0)

Change History (1)

comment:1 by anonymous, 13 years ago

Resolution: duplicate
Status: newclosed

Duplicate of #2464.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.