Edgewall Software
Modify

Opened 11 years ago

Closed 11 years ago

#4596 closed defect (duplicate)

ValueError: 2007-01-26 오후 5:20:16 is invalid or not a known date format

Reported by: Benn Owned by: anonymous
Priority: normal Milestone:
Component: general Version: devel
Severity: normal Keywords: timeformat
Cc:
Release Notes:
API Changes:

Description (last modified by Christian Boos)

How to Reproduce

While doing a POST operation on /admin/ticket/versions, Trac issued an internal error.

{'__FORM_TOKEN': u'77cd8cfb185a4ae004261f14',
 'add': u'Add',
 'cat_id': u'ticket',
 'name': u'dev',
 'panel_id': u'versions',
 'path_info': None,
 'time': u'2007-01-26 \uc624\ud6c4 5:20:16'}

System Information

Trac 0.11dev
Python 2.5 (r25:51908, Sep 19 2006, 09:52:17) [MSC v.1310 32 bit (Intel)]
SQLite 3.3.4
pysqlite 2.3.2
Genshi 0.3.6
Subversion 1.4.3

Python Traceback

Traceback (most recent call last):
  File "C:\DE\Python\25\Lib\site-packages\trac\web\main.py", line 395, in dispatch_request
    dispatcher.dispatch(req)
  File "C:\DE\Python\25\Lib\site-packages\trac\web\main.py", line 213, in dispatch
    resp = chosen_handler.process_request(req)
  File "C:\DE\Python\25\Lib\site-packages\trac\admin\web_ui.py", line 96, in process_request
    path_info)
  File "C:\DE\Python\25\Lib\site-packages\trac\ticket\admin.py", line 229, in render_admin_panel
    ver.time = datefmt.parse_date(req.args.get('time'))
  File "C:\DE\Python\25\Lib\site-packages\trac\util\datefmt.py", line 114, in parse_date
    raise ValueError('%s is invalid or not a known date format' % text)
ValueError: <unprintable ValueError object>

Attachments (0)

Change History (3)

comment:1 Changed 11 years ago by anonymous

Milestone: 0.11

comment:2 Changed 11 years ago by anonymous

Owner: changed from Jonas Borgström to anonymous
Status: newassigned

comment:3 Changed 11 years ago by Christian Boos

Description: modified (diff)
Milestone: 0.11
Resolution: duplicate
Status: assignedclosed

Looks like a duplicate of #2182.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain anonymous.
The resolution will be deleted.
to The owner will be changed from anonymous to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .

 
Note: See TracTickets for help on using tickets.