Edgewall Software
Modify

Opened 18 years ago

Closed 17 years ago

#4561 closed defect (duplicate)

case sensitivity with login information on windows and duplicate user entry in session table

Reported by: Karmadude <karmadude@…> Owned by: Jonas Borgström
Priority: high Milestone:
Component: general Version: 0.10.3
Severity: major Keywords: iexplorer7
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

I have trac setup to use windows domain authentication. When I login using firefox, everything is in lowercase, and and entry is made in session table:

example: domain\username

Now if I login from IE7, since I am on the domain, IE7 automatically logs me in, but everything is in uppercase now and a second entry is made to the session table for the same user, but with uppercase characters.

example: DOMAIN\UserName

Attachments (0)

Change History (4)

comment:1 by Emmanuel Blot, 18 years ago

Milestone: 0.10.4
Severity: blockercritical

comment:2 by Christian Boos, 17 years ago

Milestone: 0.10.4
Priority: highesthigh
Severity: criticalmajor

See also #4560. It's not yet clear yet whether the "Missing or invalid form token. Do you have cookies enabled?" error reported there is caused by the problem reported here or not.

comment:3 by Christian Boos, 17 years ago

Keywords: iexplorer7 added; IE7 removed

comment:4 by Christian Boos, 17 years ago

Milestone: 0.10.4
Resolution: duplicate
Status: newclosed

See #2310.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.