Edgewall Software
Modify

Opened 15 years ago

Closed 15 years ago

#4438 closed enhancement (worksforme)

Why is there no filename in timeline and revision histroy?

Reported by: anonymous Owned by: Christian Boos
Priority: low Milestone:
Component: timeline Version: 0.10.3
Severity: minor Keywords: filename, timeline, browse source
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

Hi,

it would be very useful if there were the belonging file name to the revision listed, too. Or is there any reason for not showing the filename?

E.g.:

http://trac.edgewall.org/timeline

http://trac.edgewall.org/log/trunk

Attachments (0)

Change History (6)

comment:1 by Emmanuel Blot, 15 years ago

I'm not sure to understand the request:

Timeline (or log) cannot contain the filename list as there could be potentially a huge list of files tied to a single changeset. However, each change contains a link to the actual file list.

Can you elaborate your request?

comment:2 by Emmanuel Blot, 15 years ago

Keywords: needinfo added; filename removed

comment:3 by Matthew Good, 15 years ago

There is the changeset_show_files option to enable showing a limited # of files in the timeline. However, I'm not sure if this was intended as a "task" ticket to enable this option on t.e.o, or if this is really meant as an "enhancement" request.

comment:4 by Christian Boos, 15 years ago

Keywords: needinfo removed
Resolution: worksforme
Status: newclosed

I think that was an enhancement request for the already existing feature. See also #3274.

comment:5 by anonymous, 15 years ago

Component: browsertimeline
Keywords: filename timeline browse source added
Priority: normallow
Resolution: worksforme
Severity: normalminor
Status: closedreopened
Type: taskenhancement

@eblot: The Problem is, that you have only the commit comment and the revision number in the timeline, you can't see which was modified. I don't want to click on the line to which file or dir it was. Or I don't want to put the filename into the comment.

@mgood: where can i enable changeset_show_files, can't find anything in trac settings

In "browse source" → "truc" it is the same thing, i have to click through the whole dir path to in which file/dir the commit was. There should be a further column named "path" or "file" or "last change in".

in reply to:  5 comment:6 by Matthew Good, 15 years ago

Resolution: worksforme
Status: reopenedclosed

Replying to anonymous:

@mgood: where can i enable changeset_show_files, can't find anything in trac settings

In my comment above I linked directly to the section in the documentation describing that setting: TracIni#timeline-section

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Christian Boos.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Christian Boos to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.