Edgewall Software
Modify

Opened 15 years ago

Closed 15 years ago

#4353 closed defect (duplicate)

If milestone name contains url-quoted chars, such milestone can't be found in DB

Reported by: mcv@… Owned by: Christopher Lenz
Priority: normal Milestone:
Component: roadmap Version: 0.10
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

How to reproduce:

  1. Create milestone with reserved chars, for ex. "12/12/06"
  2. Try to click on it in Roadmap view.

Result: Trac gives error: "Internal Error Milestone 12%2F12%2F06 does not exist."

Expected: Trac should successfully retrieve milestones with such names from DB

Quick patch: model.py:

        cursor = db.cursor()
+        import urllib
+        name = urllib.unquote(name)
        cursor.execute("SELECT name,due,completed,description "
                       "FROM milestone WHERE name=%s", (name,))
        row = cursor.fetchone()

Attachments (0)

Change History (1)

comment:1 by Christian Boos, 15 years ago

Resolution: duplicate
Status: newclosed

Duplicate of #1816. You may want to install the latest stable version of 0.10-stable.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Christopher Lenz.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Christopher Lenz to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.