Edgewall Software
Modify

Opened 16 years ago

Closed 15 years ago

#4328 closed defect (duplicate)

Unable to delete custom report

Reported by: anonymous Owned by: Jonas Borgström
Priority: normal Milestone:
Component: general Version: 0.10.2
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

I was unable to delete the following custom report:

SELECT p.value AS __color__,
   ' Release' AS __group__,
   (CASE status WHEN 'assigned' THEN owner||' *' ELSE owner END) AS owner,
   id AS ticket, summary, t.type AS type, 
   status, resolution,
   (CASE status 
      WHEN 'closed' THEN 'color: #777; background: #ddd; border-color: #ccc;'
      ELSE 
        (CASE owner WHEN '$USER' THEN 'font-weight: bold' END)
    END) AS __style__,
   component, version, 
   changetime AS _changetime, description AS _description,
   reporter AS _reporter
  FROM ticket t, enum p
  WHERE status IN ('new', 'assigned', 'reopened') 
AND p.name = t.priority AND p.type = 'priority'
  ORDER BY owner, id, p.value, t.type, time

The traceback was:

Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/trac/web/modpython_frontend.py", line 206, in handler
    dispatch_request(mpr.path_info, mpr, env)
  File "/usr/lib/python2.4/site-packages/trac/web/main.py", line 139, in dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.4/site-packages/trac/web/main.py", line 107, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/lib/python2.4/site-packages/trac/ticket/report.py", line 115, in process_request
    self._render_confirm_delete(req, db, id)
  File "/usr/lib/python2.4/site-packages/trac/ticket/report.py", line 198, in _render_confirm_delete
    req.hdf['report'] = {
AttributeError: 'module' object has no attribute 'row'

Attachments (0)

Change History (2)

comment:1 by anonymous, 16 years ago

I had created another report with the same name, but different id number before trying to delete this report. Changing the name of the report I wanted to delete did not allow me to delete the report.

comment:2 by Christian Boos, 15 years ago

Resolution: duplicate
Status: newclosed

Duplicate of #2613… You probably don't have 0.10.2, but 0.9.3, as this issue has been fixed in 0.9.4.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.