Edgewall Software
Modify

Opened 13 years ago

Closed 13 years ago

#4227 closed defect (worksforme)

Postgres Milestone table definition not the same as SQLite

Reported by: nick.stone@… Owned by: Jonas Borgström
Priority: normal Milestone:
Component: general Version: 0.10
Severity: major Keywords:
Cc: Branch:
Release Notes:
API Changes:

Description

The definition of the Milestone table for Postgres and SQLite is different. This is causing problems when converting between the two but I imagine may also cause problems elsewhere. I ve included the definitions that get created below:

SQLite def:

CREATE TABLE milestone (
    name            text PRIMARY KEY,
    due             integer, -- Due date/time
    completed       integer, -- Completed date/time
    started        integer, -- Started date/time
    description     text
)

Postgreql def:

CREATE TABLE milestone
(
  name text NOT NULL,
  due int4,
  completed int4,
  description text,
  CONSTRAINT milestone_pkey PRIMARY KEY (name)
) 
WITHOUT OIDS;

I'm happy to create a fix if somebody points me in the right direction

Attachments (0)

Change History (3)

comment:1 by nick.stone@…, 13 years ago

Resolution: fixed
Status: newclosed

Sorry all - the problem is the burndown plug-in that we're using off the Trac-hacks site. My appologies for posting that here..

comment:2 by Christian Boos, 13 years ago

Resolution: fixed
Status: closedreopened

comment:3 by Christian Boos, 13 years ago

Milestone: 0.10.4
Resolution: worksforme
Status: reopenedclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.