Edgewall Software
Modify

Opened 15 years ago

Closed 15 years ago

Last modified 6 years ago

#4210 closed enhancement (duplicate)

Request for tweak to show user's name instead of account in "assign"/"assigned" pulldowns.

Reported by: anonymous Owned by: Jonas Borgström
Priority: normal Milestone:
Component: ticket system Version: 0.10.2
Severity: normal Keywords: name pulldown assign assigned
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

Unfortunately I'm stuck with an unrecognizable enterprise standard for the account name. We have enough users where we can't keep cross referencing manually. Having the person's name in place of the account would be PERFECT! I don't mind a hack in the short-term.

Attachments (0)

Change History (5)

in reply to:  description ; comment:1 by anonymous, 15 years ago

Replying to anonymous:

Unfortunately I'm stuck with an unrecognizable enterprise standard for the account name. We have enough users where we can't keep cross referencing manually. Having the person's name in place of the account would be PERFECT! I don't mind a hack in the short-term.

I'm relatively new to trac, but already a vivid user. Unfortunately I know little about configuring it, which is why I'm asking myself if the assign/reassign function can be changed from text entry field to pull-down via configuration. The text entry field here bugs me too, if that’s what this ticket is about. You can easily mistype the user name of the person you'd like to assign the ticket to and then it's not lossed, but kind of out of focus.

I too would be prefer a pulldown menu offering all users involved in the project.

in reply to:  1 comment:2 by Emmanuel Blot, 15 years ago

Replying to anonymous:

if that’s what this ticket is about.

No, I don't think the ticket is related to your "issue".
This ticket is about displaying a real user name rather than a sometimes cryptic login name, e.g. "Joe User" instead of "ju1234".

I too would be prefer a pulldown menu offering all users involved in the project.

Read TracFaq#how-to-get-a-drop-down-user-list-for-ticker-owners

comment:3 by anonymous, 15 years ago

Exactly. I'm able to select the assignee by id in the pulldown. Eblot described my issue better than I did! :)

comment:4 by Emmanuel Blot, 15 years ago

See also #4266

comment:5 by ThurnerRupert, 15 years ago

Resolution: duplicate
Status: newclosed

seems to be a duplicate of #3737. instead of tweaking the gui, the simpler solution should be to separate "login-uid" and "trac-uid" or "nick".

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.