Edgewall Software
Modify

Opened 13 years ago

Closed 12 years ago

#4191 closed enhancement (duplicate)

CORE - Allow Removal of navigation items from within trac.ini

Reported by: ilias@… Owned by:
Priority: low Milestone:
Component: general Version: devel
Severity: trivial Keywords:
Cc: Branch:
Release Notes:
API Changes:

Description

The goal is to allow easy customization, without alteration of code and templates.

Thus the scope of this ticket is very small.

Suggested implementation:

mainnav = wiki, -timeline, …

The timeline item would be removed in this case (prefix with "-"). Another option would be the "!", but this could be missleading with the functionality within the wiki

Attachments (2)

EnableNavItemRemoval.diff (735 bytes ) - added by ilias@… 13 years ago.
EnableNavItemRemoval2.diff (790 bytes ) - added by ilias@… 13 years ago.

Download all attachments as: .zip

Change History (13)

comment:1 by simon-code@…, 13 years ago

There are already ways of doing this:

  • Using permissions. A user/group without WIKI_VIEW will not see the menu.
  • Disable the module. If you want to hide the Timeline, just disable it in trac.ini:
    [components]
    trac.Timeline.TimelineModule = disabled
    

If the intention is not to use a feature as the Timeline, it is much better to disable it than merely to hide the navigation.

comment:2 by Noah Kantrowitz (coderanger) <coderanger@…>, 13 years ago

This is also a pretty trivial plugin. Perhaps a Request-a-Hack is in order?

comment:3 by Matthew Good, 13 years ago

Keywords: needinfo added
Priority: normallow
Severity: normaltrivial

I think disabling modules is generally the preferable solution. Removing permissions will still leave those modules visible to users with TRAC_ADMIN permission.

Do you have a specific reason to leave a module enabled, but inaccessible through the UI? I think this is a wontfix or worksforme since disabling the module already does what you've asked for, but I'll leave it open temporarilly for feedback.

in reply to:  3 comment:4 by ilias@…, 13 years ago

Replying to mgood:

I think disabling modules is generally the preferable solution. Removing permissions will still leave those modules visible to users with TRAC_ADMIN permission.

Do you have a specific reason to leave a module enabled, but inaccessible through the UI?

The reason is to provide flexibility in the interface-customization.

I could e.g. remove the "help/guide", "about" menus and enable them in another location of the UI.

The goal is to enable users to customize trac without interventions which make seperate maintenance neccessary (e.g. custom templates). This way those users can keep their "custom-trac" closer to the original one, enabling back-contribution of their code to the trac project.

I think this is a wontfix or worksforme since disabling the module already does what you've asked for, but I'll leave it open temporarilly for feedback.

I've seen several user requests asking for this functionality.

And I've seen several sites {http://code.djangoproject.com/ see example] which remove such navigation links, without disabling the content.

Trac should simplify the creation of Custom Versions

comment:5 by Noah Kantrowitz (coderanger) <coderanger@…>, 13 years ago

This has been implemented in a plugin. I would propose a wontfix for this ticket.

in reply to:  5 ; comment:6 by ilias@…, 13 years ago

Replying to Noah Kantrowitz (coderanger) <coderanger@yahoo.com>:

This has been implemented in a plugin. I would propose a wontfix for this ticket.

What you (or any other person, even committers of trac) implements as a plugin on "trac-hacks" has no relevance to the state of this ticket, which affects the core of trac.

(sidenote: Similar tickets could e.g. ask to integrate existing plugin-functionality where it belongs to: to the core)

The Plugin mechanism is an powerfull mechanism, which (when not used correctly), can lead to a very bad design and usability (as it's currently the status with trac, which needs a hand-full of un-coordinated plugins to become operative/usable in typical environments).

Of course I am not going to install and maintain for every tiny bit of functionality a plugin.

As to your plugin description: you should at least point to this ticket (from which your implementation idea originates).

And finally: having 2 options "-" and "!" should be avoided ("!" for the reason stated, as it's missleading/conflicting with the wiki functionality).

in reply to:  6 comment:7 by ilias@…, 13 years ago

by ilias@…, 13 years ago

Attachment: EnableNavItemRemoval.diff added

comment:8 by ilias@…, 13 years ago

The provided patch implements this functionality within the core, providing users with a simple intuitive way to customize the trac UI. The implementation does not break existent behaviour.

attachment:ticket:4191:EnableNavItemRemoval.diff

by ilias@…, 13 years ago

Attachment: EnableNavItemRemoval2.diff added

comment:9 by ilias@…, 13 years ago

provided patch did not work on multiple removals.

New patch uses a duplicate of the list:

attachment:ticket:4191:EnableNavItemRemoval2.diff

comment:10 by ilias@…, 13 years ago

Keywords: needinfo removed
Owner: Jonas Borgström removed

willfix or wontfix?

comment:11 by Christian Boos, 12 years ago

Resolution: duplicate
Status: newclosed

Superseded by #2060.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.