Edgewall Software
Modify

Opened 13 years ago

Closed 13 years ago

#4172 closed defect (duplicate)

No changeset N in the repository, again

Reported by: Matt Shin Owned by: Christian Boos
Priority: normal Milestone:
Component: version control Version: 0.10
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:

Description

We are getting a No changeset N in the repository error in 0.10.1 and 0.10.2, but not 0.10.0. I believe the problem was introduced at r3988, as it does not occur at r3987, (and the HEAD of 0.10-stable works correctly if we revert the change at r3988).

Repository checkins event provider (ChangesetModule) failed:

NoSuchChangeset: No changeset N in the repository

The problem occurs following a reinstallation of Trac and restarting of the web server. When we commit a new changeset into the Subversion repository afterwards, and try to view the timeline or the new changeset, we get the above error. The error appears by random if we try to reload the timeline/changeset subsequently. Browse source does not give the error, but the last changed revision of the changed file would be random: it would either be displayed correctly or it would be the revision before.

We are running RHEL 4.4, with:

  • httpd 2.0.52
  • mod_python 3.1.3
  • python 2.3.4
  • python-sqlite 1.1.7
  • sqlite 3.3.3
  • svn 1.3.2

Attachments (0)

Change History (1)

comment:1 by Christian Boos, 13 years ago

Milestone: 0.10.3
Resolution: duplicate
Status: newclosed

Yes, the issue is now understood, see #4132. There will be a fix soon.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Christian Boos.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Christian Boos to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.