Edgewall Software
Modify

Opened 16 years ago

Closed 16 years ago

#4129 closed defect (duplicate)

UTF-8 encoding in SVN trouble

Reported by: jerome@… Owned by: Jonas Borgström
Priority: normal Milestone:
Component: general Version: 0.10.1
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description (last modified by Emmanuel Blot)

Hi,

I get the followimg errors messages while trying to pointing trac to my SVN repository : Traceback (most recent call last):

 File "/usr/lib/python2.3/site-packages/trac/web/main.py", line 379, in dispatch_request
   dispatcher.dispatch(req)
 File "/usr/lib/python2.3/site-packages/trac/web/main.py", line 230, in dispatch
   resp = chosen_handler.process_request(req)
 File "/usr/lib/python2.3/site-packages/trac/versioncontrol/web_ui/browser.py", line 131, in process_request
   self._render_directory(req, repos, node, rev)
 File "/usr/lib/python2.3/site-packages/trac/versioncontrol/web_ui/browser.py", line 156, in _render_directory
   changes = get_changes(self.env, repos, [i['rev'] for i in info])
 File "/usr/lib/python2.3/site-packages/trac/versioncontrol/web_ui/util.py", line 37, in get_changes
   changeset = repos.get_changeset(rev)
 File "/usr/lib/python2.3/site-packages/trac/versioncontrol/cache.py", line 41, in get_changeset
   self.sync()
 File "/usr/lib/python2.3/site-packages/trac/versioncontrol/cache.py", line 95, in sync
   "VALUES (%s,%s,%s,%s)", (str(current_rev),
 File "/usr/lib/python2.3/site-packages/trac/db/util.py", line 47, in execute
   return self.cursor.execute(sql_escape_percent(sql), args)
 File "/usr/lib/python2.3/site-packages/trac/db/util.py", line 47, in execute
   return self.cursor.execute(sql_escape_percent(sql), args)
ProgrammingError: invalid byte sequence for encoding "UTF8": 0x80

I believe the issue is related to some character encoding issues within something in the repository. I've also noticed that when the error occurs, a transaction is held open to the database. That causes intermittent other errors when hitting other pages after someone has hit the browse page.

Any ideas about that ? Cheers

Attachments (0)

Change History (1)

comment:1 by Emmanuel Blot, 16 years ago

Description: modified (diff)
Resolution: duplicate
Status: newclosed

Duplicate of #4128.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.