Edgewall Software
Modify

Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#3727 closed defect (worksforme)

trac-admin fails

Reported by: kain Owned by: daniel
Priority: highest Milestone:
Component: admin/console Version: 0.10b1
Severity: blocker Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

www:/var/trac# trac-admin /var/trac/ranktrend upgrade : No such file or directory

www:/var/trac# trac-admin /var/trac/ranktrend initenv : No such file or directory

debian 3.1

Attachments (0)

Change History (3)

comment:1 by anonymous, 14 years ago

sorry, bad formatting, just to be clear:

www:/var/trac# trac-admin /var/trac/ranktrend initenv
: No such file or directory

www:/var/trac# trac-admin /var/trac/ranktrend upgrade
: No such file or directory

comment:2 by mkane, 14 years ago

I ran into this when trying to install trac on Fedora 5. The problem is that the scripts for trac-admin, tracd etc have a dos M character at the end of the "#!/usr/bin/env python" line.

Run dos2unix on the file and it works.

in reply to:  2 comment:3 by Matthew Good, 14 years ago

Resolution: worksforme
Status: newclosed

Replying to mkane:

I ran into this when trying to install trac on Fedora 5. The problem is that the scripts for trac-admin, tracd etc have a dos M character at the end of the "#!/usr/bin/env python" line.

The zip packages were built on Windows, so they use Windows line endings. I've updated the TracDownload page to reflect that the zip downloads are intended for Windows. Linux or Unix users should use the .tar.gz file (which in general you should anyways since it preserves executable settings and it's smaller).

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain daniel.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from daniel to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.