Edgewall Software
Modify

Opened 13 years ago

Closed 13 years ago

#3690 closed enhancement (duplicate)

patch for mimeviewer: autodetect charset by "# -*- coding: windows-1251 -*-"

Reported by: igor daniloff Owned by: Jonas Borgström
Priority: normal Milestone:
Component: version control/browser Version: 0.10b1
Severity: normal Keywords: mimeviewer charset auto coding
Cc: Branch:
Release Notes:
API Changes:

Description

* api.py.bak2

                return utf
        return self.default_charset

* api.py

                return utf
        m = re.search(r'#\s*-\*-\s+coding:\s*(\S+)\s+-\*-', content[:100])
        if m:
           return m.group(1)
        return self.default_charset

*

Attachments (0)

Change History (1)

comment:1 by Jonas Borgström, 13 years ago

Resolution: duplicate
Status: newclosed

Duplicate of #3689

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.