Edgewall Software
Modify

Opened 11 years ago

Closed 9 years ago

#3654 closed defect (fixed)

No notification on new ticket

Reported by: trac@… Owned by: Jonas Borgström
Priority: normal Milestone: 0.10.1
Component: ticket system Version: devel
Severity: normal Keywords: notification
Cc: trac@…
Release Notes:
API Changes:

Description

From the log:

Trac[web_ui] ERROR: Failure sending notification on creation of ticket #1386: unpack non-sequence
Traceback (most recent call last):
  File "/usr/local/lib/python2.3/site-packages/trac/ticket/web_ui.py", line 181, in _do_create
    tn.notify(ticket, newticket=True)
  File "/usr/local//lib/python2.3/site-packages/trac/ticket/notification.py", line 127, in notify
    NotifyEmail.notify(self, ticket.id, subject)
  File "/usr/local//lib/python2.3/site-packages/trac/notification.py", line 208, in notify
    Notify.notify(self, resid)
  File "/usr/local//lib/python2.3/site-packages/trac/notification.py", line 105, in notify
    (torcpts, ccrcpts) = self.get_recipients(resid)
  File "/usr/local//lib/python2.3/site-packages/trac/ticket/notification.py", line 225, in get_recipients
    (updater, ) = cursor.fetchone()
TypeError: unpack non-sequence

Running r3680 with MySQL backend. Ticket update notifications work.

Attachments (2)

notify-on-create.patch (1.2 KB ) - added by timwatt+trac@… 11 years ago.
Fix ticket creator notification (and generally don't let updater-related exceptions stop notification)
notify-on-create.2.patch (1.2 KB ) - added by timwatt+trac@… 11 years ago.
Fix reference to 'log'

Download all attachments as: .zip

Change History (7)

comment:1 Changed 11 years ago by timwatt+trac@…

In my specific case (as in yours), I had always_notify_updater = false, which is needed to trigger the code path you quote. The problem, as the exception implies, is that the query

SELECT author FROM ticket_change WHERE ticket=%s ORDER BY time DESC LIMIT 1

returns no results (naturally, since there are no changes recorded yet).

The patch I'm attaching solved it for my configuration, but deserves more testing (and possibly cleanup/beautification).

I wrote it against 0.10b1, but it looks like that file has not been touched since that tag (so it should apply to trunk as well).

Changed 11 years ago by timwatt+trac@…

Attachment: notify-on-create.patch added

Fix ticket creator notification (and generally don't let updater-related exceptions stop notification)

Changed 11 years ago by timwatt+trac@…

Attachment: notify-on-create.2.patch added

Fix reference to 'log'

comment:2 Changed 11 years ago by Christian Boos

Keywords: mysql notification added
Milestone: 0.10.1

comment:4 Changed 11 years ago by Christian Boos

Resolution: fixed
Status: assignedclosed

Fixed by r3808.

comment:5 Changed 9 years ago by anonymous

Keywords: email added; mysql removed
Priority: normalhigh
Resolution: fixed
Status: closedreopened

Hello everyone , I am getting the following error :

2008-10-01 07:31:34,555 Trac[web_ui] ERROR: Failure sending notification on change to ticket #2: <p>Unable to send email due to identity crisis.</p><p>Neither <b>notification.from</b> nor <b>notification.reply_to</b>are specified in the configuration.</p>
Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/trac/ticket/web_ui.py", line 992, in _do_save
    tn.notify(ticket, newticket=False, modtime=now)
  File "/usr/lib/python2.4/site-packages/trac/ticket/notification.py", line 148, in notify
    NotifyEmail.notify(self, ticket.id, subject)
  File "/usr/lib/python2.4/site-packages/trac/notification.py", line 240, in notify
    'SMTP Notification Error')

my configuration file :

# -*- coding: utf-8 -*-
[attachment]
max_size = 262144
render_unsafe_content = false
 
[browser]
color_scale = True
downloadable_paths = /trunk, /branches/*, /tags/*
hide_properties = svk:merge
intermediate_color =
intermediate_point =
newest_color = (255, 136, 136)
oldest_color = (136, 136, 255)
oneliner_properties = trac:summary
render_unsafe_content = false
wiki_properties = trac:description
 
[changeset]
max_diff_bytes = 10000000
max_diff_files = 0
wiki_format_messages = true
 
[components]
trac.web.auth.LoginModule = disabled
acct_mgr.web_ui.LoginModule = enabled
acct_mgr.web_ui.RegistrationModule = disabled
acct_mgr.htfile.HtPasswdStore = enabled
acct_mgr.admin.AccountManagerAdminPage = enabled
acct_mgr.web_ui.AccountModule = enabled
 
[header_logo]
alt = Project 
height = -1
link =
src = site/your_project_logo.png
width = -1
 
[inherit]
plugins_dir =
templates_dir =
 
[logging]
log_file = trac.log
# log_format = <inherited>
log_level = DEBUG

[milestone]
stats_provider = DefaultTicketGroupStatsProvider
 
[mimeviewer]
enscript_modes = text/x-dylan:dylan:4
enscript_path = enscript
max_preview_size = 262144
mime_map = text/x-dylan:dylan,text/x-idl:ice,text/x-ada:ads:adb
php_path = php
tab_width = 8
 
[notification]
admit_domains =
always_notify_owner = false
always_notify_reporter = false
always_notify_updater = true
ignore_domains =
mime_encoding = base64
smtp_always_bcc =
smtp_always_cc =
smtp_default_domain =
smtp_enabled = true
smtp_from = [email-id]
smtp_from_name =
smtp_password =
smtp_port = 25
smtp_replyto = [email id]
smtp_server = [server name] 
smtp_subject_prefix = __default__
smtp_user =
ticket_subject_template =  #.id:
use_public_cc = false
use_short_addr = false
use_tls = false
 
[project]
admin = 
descr = 
footer = 
icon = common/trac.ico
name = 
url =
[query]
default_anonymous_query = status!=closed&cc~=root
default_query = status!=closed&owner=root
items_per_page = 100
 
[report]
items_per_page = 100
items_per_page_rss = 0
 
[revisionlog]
default_log_limit = 100
 
[roadmap]
stats_provider = DefaultTicketGroupStatsProvider
 
[search]
min_query_length = 3
 
[svn]
branches = trunk,branches/*
tags = tags/*
 
[ticket]
default_cc = 
default_component =
default_description =
default_keywords =
default_milestone =
default_owner =
default_priority = major
default_resolution = fixed
default_severity =
default_summary =
default_type = defect
default_version =
max_description_size = 262144
preserve_newlines = default
restrict_owner = false
workflow = ConfigurableTicketWorkflow
 
[ticket-workflow]
accept = new,assigned,accepted,reopened -> accepted
accept.operations = set_owner_to_self
accept.permissions = TICKET_MODIFY
leave = * -> *
leave.default = 1
leave.operations = leave_status
reassign = new,assigned,accepted,reopened -> assigned
reassign.operations = set_owner
reassign.permissions = TICKET_MODIFY
reopen = closed -> reopened
reopen.operations = del_resolution
reopen.permissions = TICKET_CREATE
resolve = new,assigned,accepted,reopened -> closed
resolve.operations = set_resolution
resolve.permissions = TICKET_MODIFY
 
[timeline]
abbreviated_messages = true
changeset_collapse_events = false
changeset_long_messages = false
changeset_show_files = 0
default_daysback = 30
max_daysback = 90
newticket_formatter = oneliner
ticket_show_details = false
 
[trac]
authz_file =
authz_module_name =
auto_reload = False
base_url =
check_auth_ip = true
database = postgres://postgres:xxxxx@localhost/xxxxx
default_charset = iso-8859-15
htdocs_location =
ignore_auth_case = false
mainnav = wiki,timeline,roadmap,browser,tickets,newticket,search
metanav = login,logout,prefs,help,about
permission_policies = DefaultPermissionPolicy, LegacyAttachmentPolicy
permission_store = DefaultPermissionStore
repository_dir = /svn/repos/
repository_type = svn
show_email_addresses = false
timeout = 20
use_base_url_for_redirect = False
 
[wiki]
ignore_missing_pages = false
render_unsafe_content = false
split_page_names = false
 
[account-manager]
password_format = htpasswd
password_file = /var/www/trac/

i tried telnet [my smtp server] 25 connected to … escape sequence ']'

but when i type :

audit2allow -i /var/log/audit/audit.log -l

i get a relevant entry : allow httpd_t smtp_port_t:tcp_socket name_connect;

i am not getting any email :(

Any kind of remarks will be appreciated ! Thanks !

comment:6 Changed 9 years ago by Emmanuel Blot

Keywords: email removed
Priority: highnormal
Resolution: fixed
Status: reopenedclosed

This really looks like a configuration issue, so please post to the MailingList, and avoid re-opening tickets which are two years old: it is likely that your problem is unrelated to the original, fixed issue.

Please do not obfuscate the from and reply to fields as it might be the root cause of the issue.
Do not forget to include useful information, such as the Trac version.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted.
to The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .

 
Note: See TracTickets for help on using tickets.