Edgewall Software
Modify

Opened 14 years ago

Closed 14 years ago

#3483 closed defect (duplicate)

maximum recursion depth exceeded in cmp

Reported by: anonymous Owned by: Jonas Borgström
Priority: normal Milestone:
Component: version control/changeset view Version: 0.9.6
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

Hi,

I am running trac 0.9.6 on Fedora Core 4 (AMD64), with Subversion 1.2.3 and Python 2.4.1. I get a "maximum recursion depth exceeded in cmp" error when I am trying to view one of my changesets. I can view the changeset before and after this one with no issues.

Any help would be greatly appreciated,

thanks,

Ken

Python traceback

Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/trac/web/modpython_frontend.py", line 206, in handler
    dispatch_request(mpr.path_info, mpr, env)
  File "/usr/lib/python2.4/site-packages/trac/web/main.py", line 139, in dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.4/site-packages/trac/web/main.py", line 107, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/lib/python2.4/site-packages/trac/versioncontrol/web_ui/changeset.py", line 86, in process_request
    self._render_html(req, repos, chgset, diff_options)
  File "/usr/lib/python2.4/site-packages/trac/versioncontrol/web_ui/changeset.py", line 257, in _render_html
    ignore_space_changes='-b' in diff_options[1])
  File "/usr/lib/python2.4/site-packages/trac/versioncontrol/diff.py", line 179, in hdf_diff
    for group in _group_opcodes(opcodes, context):
  File "/usr/lib/python2.4/site-packages/trac/versioncontrol/diff.py", line 116, in _group_opcodes
    for idx, (tag, i1, i2, j1, j2) in enum(opcodes):
  File "/usr/lib/python2.4/site-packages/trac/util.py", line 43, in enum
    for item in iter(iterable):
  File "/usr/lib/python2.4/site-packages/trac/versioncontrol/diff.py", line 77, in _get_opcodes
    for tag, i1, i2, j1, j2 in matcher.get_opcodes():
  File "/usr/lib64/python2.4/difflib.py", line 530, in get_opcodes
    for ai, bj, size in self.get_matching_blocks():
  File "/usr/lib64/python2.4/difflib.py", line 478, in get_matching_blocks
    self.__helper(0, la, 0, lb, self.matching_blocks)
  File "/usr/lib64/python2.4/difflib.py", line 495, in __helper
    self.__helper(i+k, ahi, j+k, bhi, answer)
  File "/usr/lib64/python2.4/difflib.py", line 495, in __helper
    self.__helper(i+k, ahi, j+k, bhi, answer)
  File "/usr/lib64/python2.4/difflib.py", line 495, in __helper
    self.__helper(i+k, ahi, j+k, bhi, answer)
  File "/usr/lib64/python2.4/difflib.py", line 495, in __helper
    self.__helper(i+k, ahi, j+k, bhi, answer)

...

 File "/usr/lib64/python2.4/difflib.py", line 495, in __helper
    self.__helper(i+k, ahi, j+k, bhi, answer)
  File "/usr/lib64/python2.4/difflib.py", line 495, in __helper
    self.__helper(i+k, ahi, j+k, bhi, answer)
  File "/usr/lib64/python2.4/difflib.py", line 492, in __helper
    self.__helper(alo, i, blo, j, answer)
  File "/usr/lib64/python2.4/difflib.py", line 486, in __helper
    i, j, k = x = self.find_longest_match(alo, ahi, blo, bhi)
  File "/usr/lib64/python2.4/difflib.py", line 436, in find_longest_match
    while besti+bestsize < ahi and bestj+bestsize < bhi and \
RuntimeError: maximum recursion depth exceeded in cmp

Attachments (0)

Change History (1)

comment:1 by Matthew Good, 14 years ago

Resolution: duplicate
Status: newclosed

This is a duplicate of #2756.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.