Edgewall Software
Modify

Opened 13 years ago

Closed 13 years ago

#3385 closed enhancement (duplicate)

Please add a public API

Reported by: tomek.piatek@… Owned by: Jonas Borgström
Priority: high Milestone:
Component: general Version:
Severity: normal Keywords: api web service
Cc: Branch:
Release Notes:
API Changes:

Description

It would be super nice if Trac had some sort of a public API for querying the system and manipulating tickets. This could be implemented as a simple REST-like service.

I am currently developing a set of practices and tools designed to facilitate the process of development management. I am aware of the svn post-hook pythin script which I intend to use for now but it would be really handy to have a proper API for talking to Trac.

Attachments (0)

Change History (2)

comment:1 by Emmanuel Blot, 13 years ago

Trac is open-source, so you can manipulate the APIs as you wish from a post-hook script for example.

If you're looking for some example, check out the contributed trac-post-commit-hook script which can update or close a ticket, and send a notification as a result of a svn commit action.

You can also check out the XmlRpcPlugin to invoke the APIs remotely.

comment:2 by Matthew Good, 13 years ago

Resolution: duplicate
Status: newclosed

This is a duplicate of #217.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.