Edgewall Software
Modify

Opened 13 years ago

Closed 13 years ago

#3301 closed defect (worksforme)

Subversion error

Reported by: thomasv@… Owned by: Jonas Borgström
Priority: high Milestone:
Component: version control/browser Version: 0.9.5
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:

Description (last modified by Emmanuel Blot)

Blew away my subversion repo. Then recreated it. Got this error.


Oops…

Trac detected an internal error: ('No such revision 3411', 160006) If you think this really should work and you can reproduce it. Then you should consider to report this problem to the Trac team.

Go to http://trac.edgewall.com/ and create a new ticket where you describe the problem, how to reproduce it. Don't forget to include the python traceback found below.

TracGuide — The Trac User and Administration Guide

Python traceback

Traceback (most recent call last):
  File "/usr/lib/python2.3/site-packages/trac/web/modpython_frontend.py", line 206, in handler
    dispatch_request(mpr.path_info, mpr, env)
  File "/usr/lib/python2.3/site-packages/trac/web/main.py", line 139, in dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.3/site-packages/trac/web/main.py", line 107, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/lib/python2.3/site-packages/trac/versioncontrol/web_ui/browser.py", line 102, in process_request
    self._render_directory(req, repos, node, rev)
  File "/usr/lib/python2.3/site-packages/trac/versioncontrol/web_ui/browser.py", line 134, in _render_directory
    changes = get_changes(self.env, repos, [i['rev'] for i in info])
  File "/usr/lib/python2.3/site-packages/trac/versioncontrol/web_ui/util.py", line 33, in get_changes
    changeset = repos.get_changeset(rev)
  File "/usr/lib/python2.3/site-packages/trac/versioncontrol/cache.py", line 42, in get_changeset
    self.sync()
  File "/usr/lib/python2.3/site-packages/trac/versioncontrol/cache.py", line 82, in sync
    changeset = self.repos.get_changeset(current_rev)
  File "/usr/lib/python2.3/site-packages/trac/versioncontrol/svn_fs.py", line 251, in get_changeset
    self.fs_ptr, self.pool)
  File "/usr/lib/python2.3/site-packages/trac/versioncontrol/svn_fs.py", line 467, in __init__
    message = self._get_prop(core.SVN_PROP_REVISION_LOG)
  File "/usr/lib/python2.3/site-packages/trac/versioncontrol/svn_fs.py", line 534, in _get_prop
    return fs.revision_prop(self.fs_ptr, self.rev, name, self.pool())
SubversionException: ('No such revision 3411', 160006)

Powered by Trac 0.9.5 By Edgewall Software. Visit the Trac open source project at http://trac.edgewall.com/

Attachments (0)

Change History (2)

comment:1 by Emmanuel Blot, 13 years ago

Description: modified (diff)

Please post installation issue to the mailing list rather than submitting tickets.

Did you run trac-admin <project> resync once you have recreated your SVN repository ?

comment:3 by Matthew Good, 13 years ago

Resolution: worksforme
Status: newclosed

As eblot mentioned this should have been solved by the resync and since there's been no response I'm assuming it was.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.