Edgewall Software
Modify

Opened 16 years ago

Closed 16 years ago

Last modified 16 years ago

#3288 closed defect (fixed)

plugins in $TRAC/plugins need to be explicitly enabled

Reported by: asmodai@… Owned by: Christian Boos
Priority: normal Milestone: 0.10
Component: general Version: devel
Severity: major Keywords: plugin
Cc: coderanger@… Branch:
Release Notes:
API Changes:
Internal Changes:

Description (last modified by Christian Boos)

Since a few days/few weeks every plugin installed in trac's plugins directory underneath the trac environment needs to be explicitly enabled through [components] in trac.ini.

This is a regression from earlier behaviour.

I noticed due to getting spammed to hell and back due to the SpamFilter plugin in the plugins/ directory not auto-loading.

Attachments (0)

Change History (8)

comment:1 by Christian Boos, 16 years ago

Description: modified (diff)
Keywords: plugin added

comment:2 by Alec Thomas, 16 years ago

This was likely introduced by r3371 (global plugin directory). I don't have time to fix this now, so if somebody could take a look it would be appreciated.

comment:3 by anonymous, 16 years ago

Cc: coderanger@… added

comment:4 by coderanger@…, 16 years ago

It looks like the trouble is that line 130 compares the location of each egg to plugin_dir, but this is now a list called plugin_dirs. I am not sure why this didn't trigger an error, but the section from line 134 to 134 should be wrapped in a loop so it runs for all plugin directories.

comment:5 by Christian Boos, 16 years ago

Owner: changed from Jonas Borgström to Christian Boos
Status: newassigned

Aha, right ;)

comment:6 by Christian Boos, 16 years ago

Resolution: fixed
Status: assignedclosed

Fixed in r3434. Thanks coderanger.

I'm not sure, though, if it wouldn't make more sense to also automatically enable plugins found in the global plugins directory…

in reply to:  6 ; comment:7 by Alec Thomas, 16 years ago

Replying to cboos:

Fixed in r3434. Thanks coderanger.

Unfortunately there's still a slight problem with the fix. If the plugin is installed via setup.py develop -d /foo/plugins the egg.location will not match the plugin directory. I suspect the same may be true if the egg is symlinked. Not sure what to do about that however.

I'm not sure, though, if it wouldn't make more sense to also automatically enable plugins found in the global plugins directory…

Yeah I wondered the same thing.

in reply to:  7 comment:8 by Christopher Lenz, 16 years ago

Replying to athomas:

Unfortunately there's still a slight problem with the fix. If the plugin is installed via setup.py develop -d /foo/plugins the egg.location will not match the plugin directory. I suspect the same may be true if the egg is symlinked. Not sure what to do about that however.

That's not a new problem: it has existed ever since the enabling/disabling stuff was added before 0.9. Definitely a separate issue (and IMHO, not much of an issue).

I'm not sure, though, if it wouldn't make more sense to also automatically enable plugins found in the global plugins directory…

Yeah I wondered the same thing.

+0

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Christian Boos.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Christian Boos to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.