Edgewall Software
Modify

Opened 16 years ago

Closed 15 years ago

#3286 closed defect (worksforme)

ticket remove fails

Reported by: Markus Tacker <m@…> Owned by: daniel
Priority: normal Milestone:
Component: admin/console Version: devel
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

On r3423 i get Command failed: 'Environment' object has no attribute 'href' on a ticket remove

Attachments (0)

Change History (8)

comment:1 by Christian Boos, 16 years ago

Hm, works for me:

trac-admin $TRAC_ENV ticket remove 22

Ticket 22 and all associated data removed.

Can you try to instrument the code in order to see where this error is coming from?

comment:2 by Markus Tacker <m@…>, 16 years ago

Sorry I'm not speaking python.

comment:3 by Christian Boos, 16 years ago

Ah, found it: this must come from the SpamFilter. As a quick workaround, try disabling the SpamFilter while performing the ticket remove.

comment:4 by Markus Tacker <m@…>, 16 years ago

No, SpamFilter is not enabled on this installation.

Any ideas on which files to check the usage of .href?

Debug log says nothing.

comment:5 by Christian Boos, 16 years ago

Ah, that was my first guess. But then it must be some other plugin that implements the ITicketChangeListener and that makes use of the (non-existent) href attribute of the env within its ticket_deleted callback.

comment:6 by Markus Tacker <m@…>, 16 years ago

Hm, no. Currently I am using Account Manager and Trac Admin, but the error persists if both are disabled (commented out).

So my trac ini looks like ;[components] ;acct_mgr.* = enabled ;webadmin.* = enabled

comment:7 by Markus Tacker <m@…>, 16 years ago

With another installation on the same server it works. May there be a config setting which causes this?

comment:8 by Christian Boos, 15 years ago

Resolution: worksforme
Status: newclosed

It was possibly a bug with 0.10.x under some (unknown) circumstances, but with 0.11, this can't happen anymore, as the .href is always a valid property of the Environment.

So I'm closing this as worksforme, 0.11 speaking, as the issue is not frequent/important enough to bother with 0.10.x.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain daniel.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from daniel to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.